No announcement yet.

Amp stopped working. help! cant figure it out.

  • Filter
  • Time
  • Show
Clear All
new posts

  • Amp stopped working. help! cant figure it out.

    Hey team!

    So i've got a little problem that im struggling to work out. I recently bought a new amp (alpine MRX-f65) 4 6x9 speakers (alpine SPR-69) and a new battery. I got them mainly for a massive bush trip with a bunch of mates over new years so we could party on in the middle of nowhere.

    I was in a bit of a rush to get the boxes built and speakers wired up before we left so i only ended up only hooking up 2 of the 6x9s.

    Here's what i did.
    Click image for larger version

Name:	speaker wiring diagram.jpg
Views:	1
Size:	447.4 KB
ID:	2309694

    It all worked fine for the trip, played loud and most of the time. How ever when i got home i noticed the 6x9s in the boot weren't working so i started fiddling with settings on the amp (the sub amp next to it seems to be working okay, a bit quieter i think from the fiddling not sure what i did, i was pretty hung over...) So the amp is on, the light lights up and it gets a bit warm but there's no movement from the speakers at all. there doesn't seem to be any protection mode indicator lights (although it says it has it).

    I have checked the fuses, the RCA leads work (swapped them with the subs amp) i'm pretty convinced that the ground point is solid is there any harm in only hooking up 2 of the 4 outputs without bridging?

    Any advice would be appreciated! what should i be looking for?


  • #2
    I am not sure what the problem is ,have you checked software settings , see if balance isnt set to left only , als take out the speakers and test them on a different system , if they work you ruled them out.

    as far as amps go , I know it isnt an issue to hook up a left and right channel on a 4 channel amp, not sure how it works if you only connect right channels , but I dont think it can be harmful.
    View my worklog here


    • #3
      ^ i've been told in the past that some amps don't like powering only a single channel, so it is possible something got cooked....
      My OLD 2001 Mitsubishi Eclipse GT:
      "The Project That Never Ended, until it did"

      next project? subaru brz
      carpc undecided