No announcement yet.

I think I broke it..

  • Filter
  • Time
  • Show
Clear All
new posts

  • I think I broke it..

    Hi. I have been running my system now for a few days, but since yesterday, my sub is not working. I have it plugged into the 2 sub outputs on the rear of my stereo deck, but it is not near as loud as before. It used to thump heavily, so i kept it down on the 0 setting (-10 to +10). But now it doesnt thump at all! I can BARELY hear audio coming from it, but not much. I plug the sub's 70w amp directly into the PC or the XMD and it thumps HEAVY! What could have happened to my deck? I reset the unit but that didnt help. Any ideas would be nice. I have the Aiwa CDC-X304 unit. Thanks a bunch.

    Now that I have had this large sub - the music without one sounds soooo horrible...

  • #2
    check rca


    • #3
      Kicker: Did you edit your post? This isn't the same one I got in the email from Anywho - No I am not running the sub right from the deck. I have a 70w amp (mentioned above) that worked GREAT.

      Check which RCAs and check for what?


      • #4
        I think he means to check the RCAs (or patch cables) that connect your head unit to your subwoofer amplifier. There's a few things that could be wrong. The plugs at either end could have come loose. If its a tight fit behind the head unit, the stress on the cable could have caused it to short out. The cable cut have been nicked or cut somewhere from the the head to the trunk... etc...

        When you pluged the amp direct into the pc, did you use a different set of cables? If so, try using the same cables as you use normally. Does your head unit have another output, like front/rears? Try those for awhile, but make sure you set your low pass filter on the amp first.


        • #5
          Adam - thanks for the reply. I did use a different cable to connect the amp to the PC. I will see about testing the other cable in a few minutes and I'll let you know. The deck has 2 outputs, left and right. These can be changed from REAR to SUB in the radio's setup menu. Let me test that cable.... -BW


          • #6
            Weird - simply weird...... It wasnt working, but when I used the same cable and plugged it into the XMD it worked LOUD. So it's not the cable... But after playing and switching cables and doing everything it seems to be thumping again --??? I have no clue why - but it is. It doesnt seem to be quite as loud as before, but at least its almost there. I am really confused on this one, let me tell you! -Brett W


            • #7
              Well... then good job! If pulling out the cables and reconnecting them seems to have solved the problem, then it sure sounds like it was a loose connection. Make sure when you slip the plugs back onto the jacks that they are tight and don't easily slide back off.