Announcement

Collapse
No announcement yet.

Has any one used Performance Teknique ICBM 5.1 amp?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Has any one used Performance Teknique ICBM 5.1 amp?

    Features:

    Satellites (front & Rear, Center) Power @ 2 OHM : 100W x 5CH
    Subwoofer Power @ 2 OHM 360W x 1CH
    Frequency Response : 10Hz - 30 KHz
    THD : <0.05%
    Signal to Noise : 120db
    Channel Separation : 80db
    High Pass Filter: 40Hz- 240Hz
    Low Pass Filter: 40Hz - 240Hz
    Input Impedance: 47K OHMS
    Input Sensitivity: 0.2V -6V
    Damping Factor: > 400 @ 4 OHM, 20Hz
    Fuse Rating : 30A x 3
    Dimensions(L) : 450 mm

    Lowest $269 shipped...wondering if any one using this...

    I am ready to put my system in the car ...waiting for an amp and wiring.

    Link
    Attached Files
    ZOTS

  • #2
    That thing looks real nice! Haven't heard of it, so tell me how she went
    List of front-ends/usefull apps
    XTroniC | XTroniC Direct

    Comment


    • #3
      This should tell you:

      http://forums.caraudio.com/vb/showth...mance+teknique

      http://forums.caraudio.com/vb/showth...mance+teknique

      http://forums.caraudio.com/vb/showth...mance+teknique

      Nuf said...

      BTW those specs, especially the SNR and damping factor, MUST be WAY over rated.
      Aura MR62 (F and R)
      My Current MP3s
      IamDefiler.com

      Comment


      • #4
        I'll bump this up cause I was wondering the same thing.

        Defiler - Those links don't work anymore. Any thoughts on this amp? Thanks!

        -Ben

        Comment


        • #5
          I can't seem to find the threads as well but from what I can recall they were not very good and seemed to have fluffed specs.
          Aura MR62 (F and R)
          My Current MP3s
          IamDefiler.com

          Comment


          • #6
            sorry to bring an old topic up.

            I just bought this amp and installed it in my car. From my experience, it sounded great! especially when connecting via digital input. The sounds feels much natural and fulller than my previous old 4-channel pioneer amp and 4-channel sony (previously I use two amps to drive fronts and rears on the pioneer plus 2 subs on sony bridged). I recommended this product.

            Btw, I just noticed that this product has very similar features and layout to Hifonics Zeus ZX 5.1. The RCA sockets, crossover, digital & coaxial input, video in & out, speakers and power sockets location both are same! Even it has same IR receiver and remote. I ried to download the hifonics owners manual, the OSD menus are the same! The difference only on their casings.

            Comment


            • #7
              if is the same like the hifonics,it may have the same problem,this amp makes a thump when detects a digital signal,(ac3,dts).thats why i decided to not use this amp,is a shame that after paying just $289 for it,is not perfect.
              BASSRR ==> [Audio Player/MusicDB/Cd Player/Ripper/Rate/Internet Radio/Audio Capture/Youtube Video]
              RRTube ==> [View/Download Youtube Videos]
              WifiMan ==> [Wifi Manager]
              RRec ==> [Audio Capture]

              If You Want To Be Given Everything, Give Everything Up ...
              Bird York -- In The Deep --

              Comment


              • #8
                Thump

                You may not want to blame the thump on teh amp. I may be wrong about this but from what I have read on this forum, thumps in sound are caused in other ways (power/startup issues). Like I said I may very well be wrong but I think you might want to trouble shoot before you dismiss the amp.
                Audio - Performance Teknique 5.1 Digital Amp, Kappa Perfect 12" VQ

                Comment


                • #9
                  Good first post.
                  The thump is not realated to the amp. There are relays that people have used to delay the amp turn on so it turns on after the computer/soundcard has started, this avoids the thump.
                  Installed
                  Asus A7N8X-VM - AMD Mobile Athlon 2400
                  512 Ram - 60GB HD - Opus 150w
                  Lilliput 7" - Rikaline 6010
                  [00000000000001100010-] 98% Completed

                  Check Out My Install!!!

                  Comment


                  • #10
                    Actually, The Hifonics will produce a thump when switching certain DIGITAL inputs. This has nothing to do with sound card startup. I found a lot depends on the S/PDIF implementation. My Via M1000 had this problem with the old sound drivers, also some strange distortion. The new drivers eliminated this problem. I can still get a thump occasionally when switching from DTS to PCM or vice versa, but I hardy ever use DTS.

                    PS, It looks like Performance Tecknique is discontinuing this amp. It is not listed on their website.
                    VIA M1000 ITX
                    512MB
                    40GB 2.5" ATA
                    Zenarc 7" touchscreen
                    M-Audio Revolution
                    Opus 90w w/remote
                    Media Car
                    New carputer in progress

                    Comment


                    • #11
                      Can you adjust the volume via the computer silders when using optical?

                      Comment


                      • #12
                        You should be able to. It acts just like any other computer hooked up to an outside amplifier. Computer sliders work on those. I currently have my comp hooked up to an outside amp surround system and I can use the sliders on my comp to adjust volume.

                        Edit: the only thing you will have to do is make sure that the amp output volume is set so that when you adjust the comp slider it actually makes a difference.
                        Audio - Performance Teknique 5.1 Digital Amp, Kappa Perfect 12" VQ

                        Comment


                        • #13
                          I have the latest hifonics 5.1 amp and he is correct. When PCM kicks in there is a pop. PCM will kick in multiple times when using certain software or watcing dvds. Its the internal decoder. This can be minimized by lowering the volume on the amplifier.

                          Its not a deal breaker at all. still a great amp. My con is that you have to turn it on manually each time
                          Take my advice: Do not try to build a system that includes EVERY feature. Start with the basics, build it to a bug free state, and THEN add on.

                          Comment


                          • #14
                            i know a lot of this amps,when i said about the thump,i mention the problem,i did say when and how,i did not said that when the amp was powering on the thump was there,i said somthing about ac3 and dts.thats all.i may be a noob in this forum,but not on audio.any ways peace.
                            BASSRR ==> [Audio Player/MusicDB/Cd Player/Ripper/Rate/Internet Radio/Audio Capture/Youtube Video]
                            RRTube ==> [View/Download Youtube Videos]
                            WifiMan ==> [Wifi Manager]
                            RRec ==> [Audio Capture]

                            If You Want To Be Given Everything, Give Everything Up ...
                            Bird York -- In The Deep --

                            Comment


                            • #15
                              I don't have this "thumb" issues on my setup. From my DVD player, if I change dvd audio from dolby 2ch to dolby ac-3 5.1 or dts 5.1 during playing of dvds I never heard any "thumb". The downside is I can't adjust volume via touchscreen on my dvd player anymore if using digital, I haven't tried using car pc yet as I haven't own one (yet)

                              Comment

                              Working...
                              X