Announcement

Collapse
No announcement yet.

Whine with a twist

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Whine with a twist

    Hey guys. I've been through the forum and I know that grounding is the issue in most of these whining cases. Been there and done that. I was trying an RCA noise suppressor (ground loop isolator) earlier and the whining went 100% away. However, the audio from my PC became somewhat garbled afterwards. Remove the isolator---whine comes back pc sounds fine. What would cause this??

    Thanks guys

    caponet1

  • #2
    try to ground a SCREW on the case and on the PSU to the body try to make it the same point your headunit is grounded - if u got a stock headunit ur prolly gonna have to rerout a grounding point and also u need to ground the inverter to the same exact spot that should take care of it all i did mine the same way and i never had any problems untill now when all my grounding points got ****ed up when i tore the car up

    Comment


    • #3
      try to ground a SCREW on the case and on the PSU to the body try to make it the same point your headunit is grounded - if u got a stock headunit ur prolly gonna have to rerout a grounding point and also u need to ground the inverter to the same exact spot that should take care of it all i did mine the same way and i never had any problems untill now when all my grounding points got ****ed up when i tore the car up for some more work

      Comment


      • #4
        Thanks for the reply xdj i'll give that a go, however, im still confused as to why the rca noise surpressor would cause the audio from the pc to garble when all other audio is fine. Anyone got any ideas?

        caponet1

        Comment


        • #5
          Found this online:
          Cheapest transformers for audio use have some problems on the sound quality, typically distorted bass response and attenuating in high-frequency response. Basically a poor transformer slows down upper frequencies and allow the low frequencies to pass first, creating what we perceive as a "fat/warm" tone. Inadequate frequency response on the low end (rolloff at like 20Hz), causes low frequencies to be "slowed", allowing the upper frequencies to be heard first, this is perceived as "barky/ brittle".
          Ground loop isolators do vary in quality, i haven't used it, but this one was recommended: http://www.jkaudio.com/pureformer.htm

          |V1 Virtual Display|

          Hard work often pays off over time, laziness always pays off right now.

          Comment


          • #6
            Great help Z! That makes perfect sense with what I was hearing. Thanks for the link. I'll check it out.

            caponet1

            Comment


            • #7
              Speaker Whine Killer

              It seems that I have encountered the same problem many other carputer users have come accross. The dreadful engine noise/audible tachometer! I eliminated my problem by grounding my CPU's power supply case to the ground on my highend (highs) amp. The Amp for my sub's didn't seem to be effected. I hope this helps, I know I need the help. Now when my power module turns on my amps "silence" until I turn up the volume.

              Comment

              Working...
              X