Announcement

Collapse
No announcement yet.

Help hooking up subs and amp? Need advice...

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help hooking up subs and amp? Need advice...

    Ok, I have looked high and low and even emailed crutchfield (yuck). I am hooking up an old Amp that I have to two new subs I just bought. I am trying to find out how to hook them up.

    Infinity Beta Digital 300 Amp
    1000w x 1 RMS bridged 4 ohms
    300w x 2 RMS 4 ohms stereo
    500w x 2 RMS 2 ohms

    I have two MB Quart ref Dual Voice Coil subs hooked up in the box to ONE speaker terminal to the outside of the sealed box.

    MB Quart DVC ref subs
    300W RMS 4 ohms DVC


    I have the amp bridged now and one speaker cable running to the speaker terminal on the box. From there, I have two speaker cables running to the subs and the subs set to a Parallel configuration. The box hits real hard and sounds nice. I think the amp is running hot and may be a function of our 100 degree weather in AZ. However, the guy I bought my speakers from says I have it running at 8 ohms. I just want to hook these up to the most efficent, COOLER option. Can anyone help?
    My BMW 2004 330i

  • #2
    are they 4 ohms per coil? (if so you cant configure it to an 8 ohm impedance).
    New System in progress:
    M10k
    Phaze TD1500 ~> Dynaudio MD130
    Phaze TD1500 ~> Seas g18rnx/p
    Zapco Ref 500.1 ~ 12" tc-9
    Behringer DCX2496 ~ Envision Electronics psu
    Transflective Xenarc

    My Car Pc Install
    My Boat Pc worklog

    Comment


    • #3
      From what I am reading, you are running two subs that are dual, four ohm voice coils... you have two choices... parallel the voice coild on each sub but run two channels... in which case you have to run the amp at 500W x 2 channel with a two ohm load on each channel... or you run the voice coils in a series/parallel (series the voice coils per sub... and then parallel the two subs) so that the amp will see a four ohm load giving you the 1000W x 1 channel at 4 ohms... if you have them all paralleled together, your amp is seeing 1 ohm and from what you've written, your amp doesn't seem to offer that as an option, which most likely means your gonna nuke your amp. does that make sense? If no, lemme (or the other car audio people here) know.

      Later!
      Coach... aka Randy! (I often forget who I really am!) ;)

      ***Too many pieces and parts to list... maybe someday I'll show'm to ya!***

      Comment


      • #4
        Originally posted by coachreed
        From what I am reading, you are running two subs that are dual, four ohm voice coils... you have two choices... parallel the voice coild on each sub but run two channels... in which case you have to run the amp at 500W x 2 channel with a two ohm load on each channel... or you run the voice coils in a series/parallel (series the voice coils per sub... and then parallel the two subs) so that the amp will see a four ohm load giving you the 1000W x 1 channel at 4 ohms... if you have them all paralleled together, your amp is seeing 1 ohm and from what you've written, your amp doesn't seem to offer that as an option, which most likely means your gonna nuke your amp. does that make sense? If no, lemme (or the other car audio people here) know.
        Nice... thats on the money.

        If you want to run a 8 ohm load, you need dual voice coil 2 ohm subs(all run is series), but you will lose half of your amp power(1000w x 1 @4ohms = 500w x 1 @8ohms)
        if you have 4ohm dual voice coils, you can run a 4 ohm mono load(series/parallel), which should be fine for your amp. If you want it to run cooler, i suggest relocating the amp to somewhere with more airflow or add a fan(s).

        Comment


        • #5
          You guys ROCK! Thanks for the help. I knew something was odd.

          The subs are DVC 4 ohms each. I think the best way, from what it sounds like, is to run them in series and parallel. This will give me a 1000W x 1 bridged at 4 ohm load correct? I may need help doing this.

          From what I am hearing, I set the two voicecoils in series on each sub (I can figure this out with the crossbar that came with the subs and the manual, no problem there). Now what do I do to run the two subs in parallel for the amp to see 4 ohms?

          Am I on the right track?
          My BMW 2004 330i

          Comment


          • #6
            And to clarify, I have the two voicecoils on each sub in parallel now, and each speaker hooked directly to the one speaker terminal on the box. It does worka dn the box sounds real good. However, from what I understand, this may not be good and my amp will not last long under this configuration. I have noticed some cutting out of the bass when temps are high. This amp does not support 1 ohm loads.
            My BMW 2004 330i

            Comment


            • #7
              Originally posted by jedi7001
              From what I am hearing, I set the two voicecoils in series on each sub (I can figure this out with the crossbar that came with the subs and the manual, no problem there). Now what do I do to run the two subs in parallel for the amp to see 4 ohms?

              Am I on the right track?
              Ya, you got it, there are two ways to wire it, in series between the two coils on a sub and then parallel the to subs together as if they are just single coil subs. just wire a coil from one sub to a coil on the other sub and the to the amp. since they're wired in series between each sub, treat each sub just like it has one coil. you can also parallel the coils on each sub and wire the subs in series, same thing but maybe a little trickier.

              Comment

              Working...
              X