Announcement

Collapse
No announcement yet.

Help rewiring for expedition speakers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help rewiring for expedition speakers

    hi i have everything set up correctly i have two jl amps a sony head unit two l7 subs and i got it professionaly yinstalled my problem is that my front speakers the left one keeps distorting while th other one is clear and also my rear right speaker keeps cutting off and on randomly there seems to be no reason...so i think its due to the wiring of the speakers how can i do this

  • #2
    many options

    first is to take it back where you had it professionally installed and tell them it's not right
    Jan Bennett
    FS: VW MKIV Bezel for 8" Lilliput - 95% Finished

    Please post on the forums! Chances are, someone else has or will have the same questions as you!

    Comment


    • #3
      c the thing is that i did not have them do that partt i had my speakers done a longggg time ago by soem one elses i want to do this on my own

      Comment


      • #4
        ok - since i can't stand ebonics I'll let someone else take this one one

        Jan Bennett
        FS: VW MKIV Bezel for 8" Lilliput - 95% Finished

        Please post on the forums! Chances are, someone else has or will have the same questions as you!

        Comment


        • #5
          1. Check the wiring of your speakers.
          2. It sounds like the front left one is blown, you'll probably need new speakers.
          3. Your right rear one sounds like an amplifier, loose wire, or bad speaker problem.
          4. Most of us speak English here, and asking questions in that language will help you get along better.

          Comment

          Working...
          X