Announcement

Collapse
No announcement yet.

Asio ( Console/AudioMulch ) + Kx + Hibernate

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Asio ( Console/AudioMulch ) + Kx + Hibernate

    hi all

    im sorry in advance if its not the right section
    this topic involves many topics and i tought it would be the best place to get answers from

    now for the issue
    im having problems using asio with kx and hibernation

    im using kx 3545b with audigy 2 zs ( sb0350 )
    on win xp pro sp3

    routing :
    winamp ( hqprocsoft + ks ) -> kx recording to asio -> console/audiomulch -> src 2/3 , 4/5 , 6/7 -> kxlt ( profx ) output to amps

    the problem im having is when i return from hibernate with audiomulch/console
    i need to restart the asio audio output ( power on console / enable audio on audiomulch )

    after that everything works ok
    i figured out that the vst shells are trying to access asio before its initialized

    i found some "solutions" and ill describe what i tried

    option 1 :
    using hibernate trigger to close audiomulch before hibernating
    and open it after
    *tried using both autoit3 and just a regular command line

    good :
    it works ok and i get sound

    not good :
    for some reason hibernate trigger opens up multiple audiomulch's ( varies between 2-10 ) - couldn't trace what im doing worng
    because of the multiple intances of audiomulch i get sound about 10 seconds after returning from hibernating and also audiomulch windows on top of my frontend ( rr )

    option 2:
    installing kx 3548
    just a couple of days ago a new version of kx drivers were released which supposed to fix this problem

    good :
    i get sound after hibernation

    not good :
    sound is wierd and distorted - doing the enable audio thing again works

    i reported this bug on kx forum , hopes it will be fixed soon

    option 3:
    click on enable audio without clicking it

    for now im using this command in a button in rr ( using kanakey ) :
    ACTIVATE;audiomulch||RUN;c:\Kanakey.exe|ALT C RETURN

    good :
    it works

    not good :
    need to manually press the button


    ---
    ok now for the questions :
    1.hibernate trigger
    anyone with a solution for this?
    i tried searching here and google on this issue and couldn't find nothing

    2.anyone knows a way to "activate"/"getfocus" outside rr that i can write a command line for hibernate trigger just to press the enable audio button?

    3.can anyone think on a different way to fix this issue?

    4.anyone else using kx and asio and not having this problem?

    important to say that i don't want to give up on hibernating cuz i don't want to wait a minute for my system to cold boot..

    thanks alot in advance ,
    madboy
    HeadUnit : Car-Pc | Processor : JBL MS-8 | Front Stage : Woofer - Mpyre 65M , Mid - Dayton RS100-4 , Tweeter - Tang-Band Ceramic 25-1719S | Subwoofer : Hertz HX250D | Amps : A/D/S PQ10 , Hifonics Olympus XI , SPL AB03445 | Wiring : Sommer , Neutrik
Working...
X