Announcement

Collapse
No announcement yet.

Baud Rates

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Baud Rates

    I need a little help with Baud rates.

    I'm using the OBD-Pros interface (serial interface through a serial-usb adapter) which works perfectly at 9600bps. The website says that the obdpros module supports baud rates up to 128000bps. I've been trying to increase the baud rate to ensure that I'm getting as quick refresh rates as possible, but as soon as I play with the baud rate in the software/windows I can't connect.

    Is there a way to successfully increase the baud rate to get the fastest transfer speed possible? Would the serial-usb adapter be limiting things?

    *Edit* Also, what is the max baud rate of the CAN OBD-II Protocol? After doing a bit more of a search I'll try using hyperterminal at different baud rates to determine if it's my software or hardware causing the problem.
    I installed my carpc into my pet Kangaroo, mate.

  • #2
    Hi NiSlo,

    To change baud rates you would do the following.

    To set the baud rate,

    1. power off and then power on the scantool

    2. Start hyperterminal set parameters to 9600 N81 and type in ATDP

    3. You should see a response ELM327 compatible...

    4. Now type ATSCS 4
    the scantool will respond with OK
    this will set the speed to 38400

    (Higher baudrates woule need 5,6,7 - 7 being 128KBPS)

    5. At this point you will not be able to type anything else as hyperterminal is set to 9600 bauds while the scantool is at 38400.

    6. Shut down hyperterminal and start a new session but now set the parameters to 38400 N81

    7. Now type in atdp and the scantool should respond with ELM327 compatible...

    8. At this point you can issue ATWCS to save the comm speed and then the scantool will always use the higher speed on powerup


    OBD II defines CAN Baudrates at 250KBPS & 500 KBPS. Most of the vehicles I am aware of use the 500 KBPS baudrates.

    Paul
    www.obdpros.com

    Comment


    • #3
      Paul,

      Out of curiosity, if vehicles use 500kbit, but the UART is only 115.2kbit how does that work without loosing data?

      Thanks

      Comment


      • #4
        basically in monitor mode the amount of data that you get on the can bus will cause you to loose some data if you monitor all messages on the can bus... This is true on all the low cost scantools OBDPro, ELM etc...

        However there are ways around this

        All the OBD II data has a set of id's allocated to it so the scantool automatically set's the filters and masks to ensure that only the obd II messages are being recieved.

        In monitor mode you can custom set the filters and masks to get a set of data that you are interested in... (This is where the mongoose etc have more bandwidth due to the higher ram availability)The OBDPro double buffers the data so compared to the ELM it will have quite a bitmore head room before issuing the BUFFER OVERFLOW command.

        To explain further...

        Say you are working with a 11 bit can vehicle and you want to find the door unlock message (just as an example)

        You could set the masks to only monitor messages originating from id's 0 to 100, start monitoring hit the door and see if you can spot a pattern, if not change masks to monitor between 100 to 200 and repeat...


        Thanks
        Paul
        www.obdpros.com

        Comment


        • #5
          Thanks michbound, I'll give that a go.

          I'm gonna need to RTFM, or more specifically the data sheet...
          I installed my carpc into my pet Kangaroo, mate.

          Comment


          • #6
            I've got another (self-inflicted) problem that started yesterday. I increased the baud rate from 56600 to 115200 and that was fine. It is deinfatley set at the new baud rate as indicated by the combination of led's when it is first powered on.

            For some reason I cannot seem to connect to it through hyperterminal, or more so that I cannot send or recive any information from it. It does say that I'm connected, but whenever I type a command (eg, ati etc) it just brings back a load of gibberish. I don't have a log file as I'm at work, but it looks similar to wingdings font which is the same sought of thing you get when the baud rate isn't correct. Also when connected at 115200, the terminal sends each charachter as I press it (the pc side rx led lights up on the module whenever I type a letter) rather than it sending the full sentance when I press enter.

            Should the settings (parity, stop bits, flow control etc) be any different when using 115200 as opposed to 56600?
            I installed my carpc into my pet Kangaroo, mate.

            Comment


            • #7
              Gibberish usually points to a baud-rate mismatch. Quite common. I'd be tempted to try Hyperterminal at some of the other baud rates - like 38400 and stuff.

              And no, the 8n1n settings (8 bits, no parity, 1 stop, no flow) is pretty common among all the scantools. If you accidentally set the flow control to hardware, sometimes you'll get nothing because Hyperterm is waiting for a 'OK, send now' message.


              Lukeyson

              Comment


              • #8
                NiSlo,

                If you did not execute an ATWCS command after changing to the new baud rates you should be able to simply power down and power back up, but the fact that you can see the LED's display the new baud rate leads me to believe that you wre able to connect at 115200 and then issue the ATWCS command, so I would redo the hyperterm settings and try again. The settings should be No parity, 8 databits, 1 stop bit and like lukeyson mentioned flow control should be set to none.

                Thanks
                Paul
                www.obdpros.com

                Comment


                • #9
                  @Lukeyson
                  I've tried every baud rate available to me in hyperterminal and still no luck. I have triple checked the connection settings and they are as you and michbound have suggested.

                  @michbound
                  I was thinking the same thing. It was a few days ago that I did it so my memory is a little hazy, but I have obviously been able to connect at 115200 to issue the ATWCS after having sent the ATSCS5 command as you mentioned, but for whatever reason I cannot now. As I also said in my earlier post, when hyperterminal is 'connected' at 115200, the pc is sending each charachter as I press it (the pc side rx led lights up on the module whenever I type a letter) rather than it sending the full sentance when I press enter. Is this normal as I don't remember it doing this before I played with the baud?
                  I installed my carpc into my pet Kangaroo, mate.

                  Comment


                  • #10
                    NiSlo,

                    If you did an ATSCS5 I think you might have connected at 57600. I would try the 57600 speed and see if that fixes the issue

                    Thanks
                    Paul
                    www.obdpros.com

                    Comment


                    • #11
                      I'm not exactly sure what the problem was but it appears that the 4 port USB hub either doesn't support or doesn't like being set to 115200. I disconnected it out of the buh and plugged it into an empty usb port on the pc. I changed the windows port setting to 57600 yet connected to the obdpros from hyperterminal at 115200. It was strange as I wasn't seeing any text at all. No charachters that I typed and not any chrachters sent back by the interface were showing up. I could tell something was happening as the lights flashed as usual when I sent 0100. Anyway I sent the atscs5 then reconnected at the lower speed, sent atwcs and she's back to normal.

                      Hooray for that!
                      I installed my carpc into my pet Kangaroo, mate.

                      Comment

                      Working...
                      X