Announcement

Collapse
No announcement yet.

Pug 306 Problems obd2/immobiliser/coils?!?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Pug 306 Problems obd2/immobiliser/coils?!?

    ok ill apologize in advance if this thread is in the wrong section, or if something im typing doesn't make sense, i know nothing about cars myself and am simply creating this thread for someone else.

    Ok the problem is with a Pug 306 2000 phase 2, basically what has happened is a chap took this car for its MOT, it passed but there was some work to be done, so after approx 2 weeks of fiddling around with the car doing god knows what, surprise surprise it doesn't run, so he sold it to us. the remote key doesn't operate the central locking anymore & the car wont start. the ignition light comes on, lights up, erverything works it just wont start?! now we do know the fuel pump doesn't work unless we provide it with direct power then its fine & there is no spark from the coils?

    The MIL light is showing on the dash so we purchased some OBD2 software and hardware, but despite our best efforts we cant retrieve any error codes, every scan we do says the car is fine, no problems.
    But obviously there is. another problem is the key its self (RFID) i believe does appear to be in a bad state? so it could also be that which is causing the problem, but we have no way of testing the key. as you can see were stuck and rather frustrated as you can imagine, is there any way to disarm the immobilizer? any help would be greatly greatly appreciated. thanks for you time =]

  • #2
    Originally posted by Solvent View Post
    ok ill apologize in advance if this thread is in the wrong section, or if something im typing doesn't make sense, i know nothing about cars myself and am simply creating this thread for someone else.

    Ok the problem is with a Pug 306 2000 phase 2, basically what has happened is a chap took this car for its MOT, it passed but there was some work to be done, so after approx 2 weeks of fiddling around with the car doing god knows what, surprise surprise it doesn't run, so he sold it to us. the remote key doesn't operate the central locking anymore & the car wont start. the ignition light comes on, lights up, erverything works it just wont start?! now we do know the fuel pump doesn't work unless we provide it with direct power then its fine & there is no spark from the coils?

    The MIL light is showing on the dash so we purchased some OBD2 software and hardware, but despite our best efforts we cant retrieve any error codes, every scan we do says the car is fine, no problems.
    But obviously there is. another problem is the key its self (RFID) i believe does appear to be in a bad state? so it could also be that which is causing the problem, but we have no way of testing the key. as you can see were stuck and rather frustrated as you can imagine, is there any way to disarm the immobilizer? any help would be greatly greatly appreciated. thanks for you time =]

    Peugeot were very late making their cars compliant. EU law only required petrol cars to be compliant from 2001. It is likely therefore that yours is not EOBD (OBD2) compliant I'm afraid - this is why you can't retrieve any codes.

    Sorry!

    Gareth

    Comment


    • #3
      Ah ok, would explain alot, weve also learnt that the ecu could be the wrong one, according to the number on the ecu its for a 206 rather then a 306. Not entirely sure why thats been fitted but i doubt its doing us any favours. thanks for the reply.

      Comment


      • #4
        I'd ask on pug306.net, its a UK based forum specifically for Pug 306s, some very knowledgeable guys on there, they should be able to help.

        Comment

        Working...
        X