No announcement yet.

Can't get obd2 to work with my program properly??

  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't get obd2 to work with my program properly??

    Ok ... i am making my own obd2 reader for my car ... the problem i have is this:

    I start my car
    I run a program called ScanTool.net_win (an odb2 reader) - it picks up the data
    I close ScanTool.net_win
    I run my program
    Everything works.

    But if i go:
    I start my car
    I run my program
    I get "no data" returned regardless of what i query

    Is there a startup command or something that ScanTool.net_win would be running 1st?
    What am i doing wrong?


  • #2

    I am one of the original authors of the software. What/whose hardware are you using? Year/make/model of the car?

    And as they say, "a comm log is worth 1000 words."

    OBDLink MX: world's smallest, fastest, most advanced OBD/Bluetooth adapter with SW and MS CAN support. Read the review to learn more.
    Need to look up a diagnostic trouble code? Try the most up-to-date, free!

    You cannot send me a private message using this forum. Use my email instead: vitaliy[@]


    • #3
      I'll bet your OBDII dongle isn't guessing the right protocol. In your software, try ATSP0 and/or various other numbers that would match your car.

      Gary (-;
      OBDGPSLogger, for logging OBDII and/or GPS data
      OBDSim, an OBDII/ELM327 software simulator
      mp3car forums: obdgpslogger, obdsim


      • #4
        The hardware works with perfectly so i think the problem is with my software ... my car is a smart roadster 2003 model.