No announcement yet.

Help with Can-Utils

  • Filter
  • Time
  • Show
Clear All
new posts

  • Help with Can-Utils


    I was wondering if anyone had experience with can-utils using a OBDII to USB adapter and was successful at sniffing canbus. I am getting stuck and unfortunately hours of research on the internet has not help me find the answer; however, I feel that I am close. Once I get this working I would like to write a tutorial, because I hate to see people as frustrated as I am.

    Vehicle: 2013 Hyundai Elantra
    Adapter: ScanTool OBDLink SX OBDII to USB (Borrowed from a co-worker)
    OS: Kali (Debian/kernel v. 3.12) --I am also tried on Mint 17 with the same results.

    I will explain what the method that I am currently using that is yielding the best results.

    1. Downloaded can-utils and compiled it. (On the Linux Mint machine I installed can-utils via the apt repository)
    2. Ran the following commands (as root):
    modprobe can
    modprobe can-raw
    modprobe slcan

    slcan_attach -w -o -f -s6 -c /dev/ttyUSB0
    (received the follow answer back "attached tty /dev/ttyUSB0 to netdevice slcan0
    Press any key to detach /dev/ttyUSB0 ..." Also the green tx/rx light on the adapter blinked once. So I believe it is talking. My car should talk on 500K baud. So I set the flag -s6 to match)

    3. In a new terminal while the previous terminal was running ran the following commands (as root) and received no errors:
    ip link set slcan0 type can
    ip link set slcan0 up

    4. I turned the car to accessory (also have tried it with the car running) and ran:
    cansniffer slcan0

    5. Here is a picture of the terminal. The program is running but no data.
    Click image for larger version

Name:	cansniffer.png
Views:	1
Size:	12.2 KB
ID:	2311181

    Any advice or documentation that you have would be MUCH APPRECIATED!