No announcement yet.

Didn't get parsable data back for cmd 00:

  • Filter
  • Time
  • Show
Clear All
new posts

  • Didn't get parsable data back for cmd 00:

    Hi Guys

    I'm having trouble getting data from my scantool. It connect, but I get "Didn't get parsable data back for cmd 00:" and things go downhill from there. I tried connecting at 38400 baud as well with no luck.

    Here is what I get from --serial-log=slog

    [email protected]:~/tmp/obdgpslogger/bin$ od -c slog 
    0000000   A   T   Z  \r   x 374 370 370 377 017   0   1   0   0  \r 370
    0000020 374 370 370 377 017   A   T   E   0  \r   x 374 370 370 377 017
    0000040   A   T   S   0  \r   x 376   x 374 370 017   0   1   0   0  \r
    0000060 370   A   T   Z  \r 224 212  \v  \b 373 003

  • #2
    Binary garbage across the serial port. An easy way to know your baudrate's squiffy.

    Try editing src/logger/obdserial.c around line 94. Before the tcsetattr, add the following:
    cfsetispeed(&options, B38400);
    cfsetospeed(&options, B38400);
    The way obdgpslogger works right now, it simply gets the serial port settings using tcgetattr, modifies the ones it cares about [canonical mode, etc], and writes those settings back using tcsetattr.

    This assumes that your {serial port, usb device driver, usb-to-serial chip} are all Doing The Right Thing(TM) and negotiating stuff right. In practice, I'm finding that a lot of people have their ports set to 9600 or 38400, but the device is set to the *other* one

    You could also try using stty to set the baudrate on the port before launching obdgpslogger [probably faster and easier than modifying code, come to think of it]:
    stty -F /dev/ttyS0 38400

    In future, I think I'm going to add command-line options to control the baudrate by hand. [My OBDPro device uses the LEDs when you power it on to tell you what baudrate it's set to]

    Lemme know if that improves things

    Gary (-;
    OBDGPSLogger, for logging OBDII and/or GPS data
    OBDSim, an OBDII/ELM327 software simulator
    mp3car forums: obdgpslogger, obdsim


    • #3
      Just for anyone following this, I really didn't make any progress with this. Gary and I discussed this in IRC and I think it's a ftdi driver issue. Even just doing a basic connectivity test with minicom barely worked, and never could get a proper conversation going. I did verify communication speeds and even managed to change the OBDPRos scantool to 38400, but it didn't help. Works fine with the windows software it came with on a real windows laptop.

      So for now I am going to shelve it. I honestly don't care about put a computer in my cars with OBDII right now, and will focus on my non-OBD and OBDI trucks!