Announcement

Collapse
No announcement yet.

obdgpslogger takes forever to open serial port

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • obdgpslogger takes forever to open serial port

    i've got an obdpro and linuxice upgraded to 9.10. I run obdgpslogger -s /dev/ttyUSB1 which is my obdpro device and obdgpslogger reports "opening serial port, this can take a while". For the next 2-3 mins, it says that. I look at my obdpro and i can occasionally see a light flicker other than the normal power on light (i think it may be a Rx or Tx light on the PC side).

    After the 3 mins, logger reports that it opened the device up correctly, the scantool failed to respond to command "00", spits out a couple sqlite create table errors and then goes silent.

    I don't see it exporting dbus signals and nghost doesn't see them either.

    any hints? are all the lights on the scantool supposed to light up?

    thanks
    Former author of LinuxICE, nghost, nobdy.
    Current author of Automotive Message Broker (AMB).
    Works on Tizen IVI. Does not represent anyone or anything but himself.

  • #2
    I've been seeing similar problems on ubuntu 9.10, but not on 9.04. unplugging and re-plugging the device usually fixes it [although if you have the same buggy ftdi driver as me, the /dev entry will change because it can't clear the old one out].

    If I try connecting to the port by hand, then it works for a while and then suddenly turns to garbage after typing for a bit.

    Thus far, it seems like this is another 9.10 manifestation-of-bugginess

    You might also try explicitly passing the --baud=9600 option, see if that helps. It shouldn't make a difference, but I have yet to see 9.10 ftdi-sio properly work right, at all.

    Gary (-;
    OBDGPSLogger, for logging OBDII and/or GPS data
    OBDSim, an OBDII/ELM327 software simulator
    mp3car forums: obdgpslogger, obdsim

    Comment


    • #3
      Found this: http://forums.parallax.com/forums/de...&m=298620&p=38

      Looks like we are not alone. I'll recommend LinuxICE users not to upgrade to 9.10 yet.
      Former author of LinuxICE, nghost, nobdy.
      Current author of Automotive Message Broker (AMB).
      Works on Tizen IVI. Does not represent anyone or anything but himself.

      Comment


      • #4
        Yes, that's exactly the symptoms I'm seeing.

        I'm actually getting to the point that I'm probably going to reinstall that laptop with 9.04 - I've been having all manner of stupid problems with 9.10 so far.

        Gary (-;
        OBDGPSLogger, for logging OBDII and/or GPS data
        OBDSim, an OBDII/ELM327 software simulator
        mp3car forums: obdgpslogger, obdsim

        Comment

        Working...
        X