Announcement

Collapse
No announcement yet.

OSX prebuilt and libgps.18.dylib

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • OSX prebuilt and libgps.18.dylib

    seems like (in addition to not being able to compile gpsd on 10.6) I'm having trouble getting gpsd to start from the osx bundle. Looking at the console app output I see this:

    1/03/10 4:41:51 PM [0x0-0x192192].org.icculus.obdgpslogger[29036] dyld: Library not loaded: /Users/chunky/gpsd//lib/libgps.18.dylib

    I'm sure I must be doing something wrong... Do I need to have a libgps.dylib someplace else (assuming I can get a 32 bit compile happening). I could make a /Users/chunky

  • #2
    Oh, good grief. Totally my bad.

    OK, so. Other than the fact that gpsd still probably won't work for you, I cooked this build from the new release:
    OBDGPSLogger-0.13-Darwin.dmg

    Lemme know if it works. My apologies for the GUI being so weak, it's slowly percolating up my list o' stuff to fix. I don't actually have a 10.6 machine yet, either, so this may not work entirely...

    Gary (-;
    OBDGPSLogger, for logging OBDII and/or GPS data
    OBDSim, an OBDII/ELM327 software simulator
    mp3car forums: obdgpslogger, obdsim

    Comment


    • #3
      Thanks Gary,

      Unfortunately I'm still seeing the libgps.18.dylib error and, running the prebuilt from the command line I'm seeing this now:

      dyld: Library not loaded: /sw/lib/libdbus-1.3.dylib

      I'm behind a firewall which won't let me install fink stuff so I can't get dbus installed at the moment - but I can try later tonight.

      I'm going to see if I can revert my build environment back to the default since it seemed to be kind of working as a 64bit command line prog before I tried getting fltk working.

      I'll let you know how I get on.

      --

      Jon

      Comment


      • #4
        Originally posted by b26354 View Post
        seems like (in addition to not being able to compile gpsd on 10.6) I'm having trouble getting gpsd to start from the osx bundle. Looking at the console app output I see this:

        1/03/10 4:41:51 PM [0x0-0x192192].org.icculus.obdgpslogger[29036] dyld: Library not loaded: /Users/chunky/gpsd//lib/libgps.18.dylib

        I'm sure I must be doing something wrong... Do I need to have a libgps.dylib someplace else (assuming I can get a 32 bit compile happening). I could make a /Users/chunky
        Hello!!! total beginner here

        I have the same problem but im on 10.5.8 macbook

        after installed your OBDGPSLogger-0.11-Darwin.dmg and drop whats on it on my desktop.

        I selected /dev/cu.usbserial for my BU-353 and when I press launch GPSD i get this

        Exception Type: EXC_BREAKPOINT (SIGTRAP)
        Exception Codes: 0x0000000000000002, 0x0000000000000000
        Crashed Thread: 0

        Dyld Error Message:
        Library not loaded: /Users/chunky/gpsd//lib/libgps.18.dylib
        Referenced from: /Users/Danny/Desktop/OBD GPS Logger.app/Contents/Resources/sbin/gpsd
        Reason: image not found

        Looking for something to edit I opened the app and found obdgpslogger and when the terminal run it says more or less the same.

        Last login: Tue Apr 6 23:21:10 on ttys000
        DannyBook-6:~ Danny$ /Users/Danny/Desktop/OBD\ GPS\ Logger.app/Contents/Resources/bin/obdgpslogger ; exit;
        dyld: Library not loaded: /Users/chunky/gpsd//lib/libgps.18.dylib
        Referenced from: /Users/Danny/Desktop/OBD GPS Logger.app/Contents/Resources/bin/obdgpslogger
        Reason: image not found
        Trace/BPT trap
        logout

        [Proceso completado]

        The GPSUtility v5 that comes with the GPS works fine. I can see it in google earth too.

        I hope you can Help. In the mean time I will try it with ubuntu. The bad thing about it is that is my old laptop and the battery is dead. So If I do something wont be on the move

        Comment

        Working...
        X