Announcement

Collapse
No announcement yet.

BU-353, gpsd, and obdgpslogger?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • BU-353, gpsd, and obdgpslogger?

    Trying to make the GPS to work. Some issues:

    1. The connection to BU-353 seems hit-or-miss. I use
    Code:
    gpsd /dev/ttyUSB0 -b -n
    and tangoGPS software to check it out. Sometimes it works. Sometimes it doesn't.

    2. The GPS coordinates show up fine in the obdgui window. However obdgui shows an error message when I close the window:
    Code:
    Couldn't SIGTERM gpsd: No such process
    and the log doesn't get saved (converted csv file only has the header line). I have to press Ctrl^C to bring back the prompt.

    Please help! Thanks!
    PriiDash(TM) open source software
    Enhanced Instrument Panel and Data Logger

  • #2
    Running it from the gui really kinda sucks, I mostly put that in there for OSX. It's much better to get gpsd configured to work with udev. Which version of ubuntu are you using, remind me?

    IIRC, you can start with "sudo dpkg-reconfigure gpsd" which lets you configure autostart.

    Gary (-;
    OBDGPSLogger, for logging OBDII and/or GPS data
    OBDSim, an OBDII/ELM327 software simulator
    mp3car forums: obdgpslogger, obdsim

    Comment


    • #3
      Originally posted by chunkyks View Post
      Running it from the gui really kinda sucks, I mostly put that in there for OSX. It's much better to get gpsd configured to work with udev. Which version of ubuntu are you using, remind me?

      IIRC, you can start with "sudo dpkg-reconfigure gpsd" which lets you configure autostart.

      Gary (-;
      Thanks! It's Ubuntu 10.04 LTS. Not sure what LTS is. It was downloaded from the Ubuntu web site not too long ago.

      Code:
      sudo dpkg-reconfigure gpsd
      helped. I just plug in the GPS and start tangoGPS and wait a short time for the coordinates to show up.
      obdgui still recognizes the coordinates and gpsd did not complain when obdgui exits.

      Thanks for the help!
      PriiDash(TM) open source software
      Enhanced Instrument Panel and Data Logger

      Comment


      • #4
        "LTS" is long-term support; most ubuntu distributions are only supported for a couple years, wheras LTS flavors are supported for more than that [can't remember the exact figures].

        If you're just a regular joe, then you probably want to be updating to new versions whenever they're released [or at least a few weeks later, in case of teething problems - 9.10 had a huge number of teething issues at release]

        So... yay! It sounds like you're up and running now?

        Gary (-;
        OBDGPSLogger, for logging OBDII and/or GPS data
        OBDSim, an OBDII/ELM327 software simulator
        mp3car forums: obdgpslogger, obdsim

        Comment


        • #5
          Thanks! Yes I usually wait until the initial bugs got fixed before jumping to a new version.

          So far I am still using the obdsim as supplied. I would like to add some more Prius specific parameters in the software before buying an OBD-USB device and run it for real. I will start a new thread on that soon.
          PriiDash(TM) open source software
          Enhanced Instrument Panel and Data Logger

          Comment


          • #6
            Yeah, start a new thread. It'll galvanise me into doing a couple things, probably...

            Gary (-;
            OBDGPSLogger, for logging OBDII and/or GPS data
            OBDSim, an OBDII/ELM327 software simulator
            mp3car forums: obdgpslogger, obdsim

            Comment


            • #7
              Originally posted by chunkyks View Post
              Yeah, start a new thread. It'll galvanise me into doing a couple things, probably...

              Gary (-;
              Done. See
              http://www.mp3car.com/vbulletin/obdi...questions.html

              By the way is there any particular way I should unplug the GPS from the laptop, i.e. some kind of "safely remove hardware" thing? Thanks!
              PriiDash(TM) open source software
              Enhanced Instrument Panel and Data Logger

              Comment


              • #8
                First GPS road test not good

                Originally posted by 2009Prius View Post
                ...
                Code:
                sudo dpkg-reconfigure gpsd
                helped. I just plug in the GPS and start tangoGPS and wait a short time for the coordinates to show up.
                obdgui still recognizes the coordinates and gpsd did not complain when obdgui exits....
                Well I don't know what may have changed but today when I tried a road test for the first time it did not go smoothly. BU-353 red LED was blinking so I know it's getting the coordinates. But tangoGPS did not show the car's movement on the map and obdgui shows all zeros for the GPS coordinates. I quit and restarted tangoGPS which fixed one problem: now it showed the correct location on the map. I quit and restarted obdgui multiple times but it still showed all zeros. I just converted the db file to csv file and the log has all zeros as well. Somehow the GPS data is not picked up by obdgpslogger. Any suggestions?

                PS. I have been unplugging and plugging the BU-353 without doing any "safely remove hardware" thing since I couldn't find any in the Ubuntu. Not sure if this is an issue or not. At least tangoGPS did pick up the data after restarting the application.
                PriiDash(TM) open source software
                Enhanced Instrument Panel and Data Logger

                Comment


                • #9
                  Tested some more: even tangoGPS failed to pick up the GPS data once, but it does work most of the time. I am still having trouble getting the GPS data to show up in obdgui.
                  PriiDash(TM) open source software
                  Enhanced Instrument Panel and Data Logger

                  Comment


                  • #10
                    This morning tangoGPS failed to get the data again even though BU-353 was blinking. odbgpsgui still shows all zeros. Is there some other way to verify that gpsd is working?
                    PriiDash(TM) open source software
                    Enhanced Instrument Panel and Data Logger

                    Comment


                    • #11
                      Made a small step forward. After some security updates ubuntu asked to restart. After restart the obdgui started to show the GPS info again! However after logging for maybe 5 or 10 minutes the gps.lon gps.lat gps.alt
                      got stuck at the same values, no longer changing, even though I was driving and tangoGPS showed the correct location on the map all the way, so GPS was working, just not passing the info to obdgpslogger correctly. Any suggestions?
                      PriiDash(TM) open source software
                      Enhanced Instrument Panel and Data Logger

                      Comment


                      • #12
                        Tried a couple of more times. obdgpslogger still only records the first few minutes of GPS coordinates and then the values got stuck at the same place. I also tried without running tangoGPS and the result is the same. Still waiting for some suggestions....
                        PriiDash(TM) open source software
                        Enhanced Instrument Panel and Data Logger

                        Comment

                        Working...
                        X