Announcement

Collapse
No announcement yet.

Need Some Help With ScanTool ELM 327.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Need Some Help With ScanTool ELM 327.

    When I hook the scantool to my car DLC (OBD 2 ) , & I choose the right settings ex: Port number and Baud Rate. It shows that it is connected and ready to use, but when I try to read codes it shows that everything is N/A Although it is connected correltly.
    I got a screenshot to the OBD information from About in the scan tool application
    and as you can see the OBD system is N/A !!! Although it reads all other information especially the Protocol correctly.

    http://img4.imageshack.us/img4/352/obdc.jpg

    My car is Nissan Tiida 1.6 ( HR16DE )

    *Sorry for double posting , but I do not know where to right this thread correctly.

  • #2
    The latest version of ELM327 is 1.3a. Yours is showing up as 1.5, which means you got ripped off (they sold you a dud).
    OBDLink MX: world's smallest, fastest, most advanced OBD/Bluetooth adapter with SW and MS CAN support. Read the review to learn more.
    Need to look up a diagnostic trouble code? Try the most up-to-date, free DTCsearch.com!

    You cannot send me a private message using this forum. Use my email instead: vitaliy[@]scantool.net.

    Comment


    • #3
      Originally posted by Vitaliy View Post
      The latest version of ELM327 is 1.3a. Yours is showing up as 1.5, which means you got ripped off (they sold you a dud).
      I know it is chinese clone, but it could read my protocol & it shows that it is properly connected!!!!. BTW I tried ELM scantool ( this one http://www.scantool.net/scan-tools/elmscan-iso-usb.html ) a year ago but it made the same problem :S it shows that it is properly connected, but it could not read codes or sensor data.
      My problem is when I choose About from that page ( http://www.scantool.net/catalog/prod...d/43/image/56/ ) and then choose OBD Information I got ( http://img4.imageshack.us/i/obdc.jpg/ ) so it could get my Protocol & the LED indications light on.
      This is the scan tool which I mean ( http://www.made-in-china.com/image/2...LM-327-USB.jpg )

      Comment


      • #4
        The point is, ELM327 v1.5 does not exist. The latest version from Elm Electronics is 1.3a. So your scan tool is not running legitimate firmware, and is probably faking a successful connection.
        OBDLink MX: world's smallest, fastest, most advanced OBD/Bluetooth adapter with SW and MS CAN support. Read the review to learn more.
        Need to look up a diagnostic trouble code? Try the most up-to-date, free DTCsearch.com!

        You cannot send me a private message using this forum. Use my email instead: vitaliy[@]scantool.net.

        Comment


        • #5
          Your car is defective. You need a new car.

          But seriously, there could be something wrong with the OBD-II port or cable if 2 different interfaces are showing the same problem. See if autozone or some place will check your car with theirs for free.

          Comment


          • #6
            Originally posted by tata12001 View Post
            My car is Nissan Tiida 1.6 ( HR16DE )
            What year is the car?

            By the way, which device reports 1.5a??

            Comment


            • #7
              That little square one says 1.5a http://www.made-in-china.com/image/2...LM-327-USB.jpg

              It's a reverse engineered one LOL It does work, but if it doesn't, well, try to get a refund I guess.

              Comment


              • #8
                Originally posted by sinclairvital View Post
                What year is the car?

                By the way, which device reports 1.5a??
                My car is 2006
                And the device is http://www.made-in-china.com/image/2...LM-327-USB.jpg

                It could read my protocol & the LED light on when it is connected, this is weird!!!

                Should I restart after changing the port number ? or after installing the driver & software ?

                BTW I did not buy it till now, but I just try it from a friend as I really need it. but the same problem appears as before

                Really I need help

                Comment


                • #9
                  Try connecting with ignition in key off position. If the scan tool still detects the protocol, it's faking it.

                  Where was the car originally purchased?
                  OBDLink MX: world's smallest, fastest, most advanced OBD/Bluetooth adapter with SW and MS CAN support. Read the review to learn more.
                  Need to look up a diagnostic trouble code? Try the most up-to-date, free DTCsearch.com!

                  You cannot send me a private message using this forum. Use my email instead: vitaliy[@]scantool.net.

                  Comment


                  • #10
                    Originally posted by Vitaliy View Post
                    Try connecting with ignition in key off position. If the scan tool still detects the protocol, it's faking it.

                    Where was the car originally purchased?
                    I tried to connect it with ignition OFF & also ON !! ,but it refused to get any information , the car engine should be running to connect to the ECU & get the information.Is there some sort of protection on the ECU ?

                    The car was purchased from Kingdom of Saudi Arabia 2006 , it is gulf specs

                    Comment


                    • #11
                      Originally posted by tata12001 View Post
                      I tried to connect it with ignition OFF & also ON !! ,but it refused to get any information , the car engine should be running to connect to the ECU & get the information.Is there some sort of protection on the ECU ?
                      Do this: make sure the ignition is completely off, go to the "OBD Information" dialog, and post the screenshot here.

                      The car was purchased from Kingdom of Saudi Arabia 2006 , it is gulf specs
                      I'm not familiar with Saudi OBD legislation; the car may or may not be OBD-II compliant.

                      Vitaliy
                      OBDLink MX: world's smallest, fastest, most advanced OBD/Bluetooth adapter with SW and MS CAN support. Read the review to learn more.
                      Need to look up a diagnostic trouble code? Try the most up-to-date, free DTCsearch.com!

                      You cannot send me a private message using this forum. Use my email instead: vitaliy[@]scantool.net.

                      Comment


                      • #12
                        Originally posted by Vitaliy View Post
                        Do this: make sure the ignition is completely off, go to the "OBD Information" dialog, and post the screenshot here.



                        I'm not familiar with Saudi OBD legislation; the car may or may not be OBD-II compliant.

                        Vitaliy
                        Ok I will try to take Screenshots as much as I can. I will get those screenshots after few days , so please be patient. If you got any solution till I get screenshots tell me.

                        Comment


                        • #13
                          Have you checked/set the baud rate to 9600 ?

                          All the best.............mintoe

                          Comment

                          Working...
                          X