Announcement

Collapse
No announcement yet.

Vista Ready board does not see XP only peripherals

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Vista Ready board does not see XP only peripherals

    Hello,

    I have a little problem here. My car computer was already built with an old dell motherboard that I had with no problem. I worked fine, it recognized all my usb devices and then one day, it just died. I guess too much vibration or something but whatever. I bought a new board. So I configure it, put it in my case and wire it to the car. When I first turned on the car, I figured it would start detecting all my usb devices.

    1. Touchscreen
    2. Mouse
    3. Zippy lighted keyboard
    4. Griffin Volume control knob
    5. CD Rom
    6. Holux GM-210 GPS Receiver
    7. Bluetooth Dongle
    8. Hauggpauge IR receiver w/ remote

    So when the board booted up, it detected the touchscreen, mouse, cd rom and bluetooth dongle. The light on the griffin is on but xp does not detect it. I unplug it and replug in and i dont here the 'ding.' Same with the GPS receiver, it shows the power light, but again, xp does not see it and with the
    same with the hauggpauge receiver. It shows the light on the front as if i was constantly pressing the button on the remote. The wierd one is the zippy keyboard. It does not even light or or work or anything.

    I had to plug in a ps2 keyboard and I went through the bios to see if there was any setting the prevented the detection of usb keyboards. None.

    So I thought that maybe it was cause it was a crappy board, so I sent it back and ordered and newer, better board.
    Again, after configuring it and wiring it back in the car. I shows the same problems. All the peripherals that didnt work before, still do not work.

    I did some research regarding Vista and I found the the Griffin does not work with Vista because Vista completely redid the say it reproduces sound, also found out that the Hauggpauge IR receiver does not work with vista because Vista only works with MS only IR receivers and I'm guessing that my Holux is already too old to work with Vista because I couldnt find any news about it and it has been discontinued.

    So my question is this. If a board is made for Vista but compatible with XP, does that make it not compatible with XP only hardware. If it doesn't, is there any thing I can do to make it recognize my hardware. Sorry for the long post but this has been bothering me for a while, thanks!

  • #2
    Well sometimes you can manually install the windows XP drivers and for each one set the file properties under compatability mode to XP SP2. While I was still testing the beta version, the nvidia 7800 graphics card had no vista drivers and then (last August or so) nvidia proudly proclaimed they wont release or even bother with vista drivers until november (business launch) so I was pretty much screwed there. So I took the XP drivers, and vista kept yelling at me saying what I was doing could corrupt the OS, and to stop what I was doing immediately. It even deleted the file once because it thought it was malicious activity I guess. I think they backed off the guarddog security a tad from then, but anyways, I set the drivers to run in compatability mode XP SP2. They worked ok, but not great. Sometimes random freezes, random resets, sometimes it would just not boot, until a reset cycle again.

    So to sum up, try compatability but if you can get it to even work, it will be shoddy at best.

    And why are you running Vista in the car anyways?! Dont get me as a "I hate Vista" bandwagon person. Microsoft sent me a copy free end of last summer to test (I think I was in the middle group of people they let in to beta legally), but honestly, right now no vista features will be helpful. In a year maybe then sure. But forntends are no good in vista, the Aero interface will always be hidden, it runs slower, and unless you do a lot of wifi connecting or cell dialup, the "new" security features wont do anything, so why vista in the car?
    Fusion Brain Version 6 Released!
    1.9in x 2.9in -- 47mm x 73mm
    30 Digital Outputs -- Directly drive a relay
    15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
    Buy now in the MP3Car.com Store

    Comment


    • #3
      2k1, he says the motherboard is labeled as a 'Vista Ready' board, not that he's trying to run Vista on it.

      And the answer is, no, a 'Vista Ready' board should be no different from an 'XP Ready' board, except that they want to slap the 'Vista' logo on it. Vista and XP would both run on the same board.

      Comment


      • #4
        Originally posted by Jahntassa View Post
        2k1, he says the motherboard is labeled as a 'Vista Ready' board, not that he's trying to run Vista on it.

        And the answer is, no, a 'Vista Ready' board should be no different from an 'XP Ready' board, except that they want to slap the 'Vista' logo on it. Vista and XP would both run on the same board.
        Whoa, completely missed that.

        Oh well.

        But yes then. The harware is identical.
        Fusion Brain Version 6 Released!
        1.9in x 2.9in -- 47mm x 73mm
        30 Digital Outputs -- Directly drive a relay
        15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
        Buy now in the MP3Car.com Store

        Comment


        • #5
          Have you reinstalled XP using the new motherboard?? It sounds like you are expecting to just swap the motherboard for a different one and for it to just magically work.

          Comment


          • #6
            Yes, I am installing XP and not Vista and yes, I have reinstalled XP on the new board cause its completely different on-board hardware. That's what I thought, just because it says Vista Ready does not mean that it only works with Vista but thats what it seems like.

            I tried installing individual drivers and still no go. One of my usb devices from home, a IR receiver (MS branded), is listed as working on both Vista and XP and the IR receiver from my car is said to only work with XP and not Vista so I tested the receiver from my house (Vista and XP Comp) on my car and it detected like a charm so that was my theory. I know it doesn't make sense.

            Any other ideas?

            BTW, thanks for the quick replies

            Comment


            • #7
              I'm thinking there's a problem with something other than the motherboard.
              You've replaced it twice with exactly the same problem recurring,and I seriously doubt that both boards (coming from different maufacturers,no less)
              could be bad.
              My bet is your power supply,or there is a loose connection somewhere that's not letting either the power supply or the board have enough current to operate normally,or a smashed set of usb cables.
              One more question,are you using a hub for all those usb devices?
              Any sufficiently advanced technology is indistinguishable from magic - Arthur C. Clarke

              Comment


              • #8
                post deleted by Rij cause he realized he was a dumbass and didnt read other posts....
                Trouble deciding on car speakers? Clicky Clicky
                Speakers: DLS Ultimate Iridium 6.3 Link
                Subwoofer: removed
                Amplifier#1 (Front Stage): DLS Ultimate A4
                Amplifier#2 (Sub) removed
                Carputer: Removed for tablet install

                Comment


                • #9
                  There are 4 ports behind the board with 4 usb extension cables (15'). One for the touch screen, one for the GPS, one for the keyboard and the last one for a usb hub.

                  The GPS has a power light on there so there is power running to it. I wanted to test the cable running to the GPS so I took a flash drive and plugged into it and XP detected right away, so that cable works fine. Same thing with the keyboard one. Plugged in the flash drive and it detected it fine and lastly with the usb hub. All ports work, I plugged the flash drive in all of them, and it detected the drive on every single one.

                  My PSU is the DSATX and Im pretty sure that I am not over the power limit as I am only powering the board, usb devices and touch screen. I just got the PSU back from Jeff because it needed the firmware upgrade so it was just tested by him, so it works fine.

                  Any other ideas, thanks

                  Comment


                  • #10
                    Try unplugging all your usb devices,and disconnect power to the usb hub....
                    then plug in one device,say the keyboard,and see if it works.If it does,then continue with the other devices until you find what's causing the conflict.
                    Any sufficiently advanced technology is indistinguishable from magic - Arthur C. Clarke

                    Comment


                    • #11
                      Tried that, unplugged everything, Touchscreen works, then unplugged and tested usb keyboard, does not work, unplugged, plugged in griffin, it lights up but is it not detected by xp and so on with the rest of the devices

                      Comment


                      • #12
                        When you reinstalled xp,did you format the hd first? If not,there might still be some registry problems,even if you removed the drivers for your devices.
                        (We know the touchscreen works,so your board is ok.)
                        Any sufficiently advanced technology is indistinguishable from magic - Arthur C. Clarke

                        Comment


                        • #13
                          I did more then format it. In my previous installation, I was using 2 hdd. A 60 gb 2.5" for the OS and a 3.5" for the media. What I did now was to get rid of the 2.5" and partition the 3.5" into 2 partitions. 20 gb for the os and the rest for the media. So I partitioned and formatted both of them. Thanks for the suggestion though.

                          I'm beginning to lose hope and am now thinking that I might be needed new, updated, vista compatible hardware ... I've even started looking for a bluetooth GPS antenna already

                          Comment


                          • #14
                            Still having this problem... Any new ideas? Thanks

                            Comment


                            • #15
                              Originally posted by jdiazj1 View Post
                              Still having this problem... Any new ideas? Thanks
                              Have you tried the items that do not work on another PC? I have had items just stop working for no reason. My Zippy keyboard did it just last night.
                              The Car 2005 Scion xB

                              The Truck 2004 GMC Canyon

                              Comment

                              Working...
                              X