Announcement

Collapse
No announcement yet.

G4 ICU Problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • G4 ICU Problem

    Hi,

    I just recently received my Infill G4 - no question I was really hyped. So I went right ahead installed XP, Service Pack 2 and
    all the drivers that came with the CD.

    When I tried installing the standard software for the G4 (Infill-Station) it told me that I couldn't continue the installation because:
    "ICU Driver is not installed or it is not an original Infill G4
    Please install Infill station after ICU driver installed"

    But the ICU Driver is installed, it's under Device-Manager->USB Hubs (driver Version 2.03)


    I tried reinstalling it a dozen times, even reinstalled my XP 3 times to no success.

    Also I tried using CentraFuse and Streetdeck, but Streetdeck won't even recognize my Radio and in CentraFuse (with Infill Plugin) the extra Infill Buttons don't do anything (flip, and brightness) also the Radio doesn't work.

    Can anyone please help ?

    kind regards,

    Ray

  • #2
    A) Where did you purchase your G4 from?
    B) If you wiped the drive and it came from here, you wiped your drivers. You must have drivers for these things to work.
    Jan Bennett
    FS: VW MKIV Bezel for 8" Lilliput - 95% Finished

    Please post on the forums! Chances are, someone else has or will have the same questions as you!

    Comment


    • #3
      Hi,

      I actually got it from here but since I live in germany I wanted
      everything as a german version. So I reinstalled Windows and
      I got the drivers from another website (not sure if I'm allowed to post URL's here) which sales the G4.

      The installation in the device-manager in windows looks absolutly
      fine, everything seemed to be there correctly (realtek sound, s3 vga, touchscreen, also the infill DFU&Com thingie)...

      I've installed following drivers (devices):
      - Infill Icu (version 2.03)
      - Audi Realtek HD
      - S3 Capture Device
      - Via Chipset Drivers
      - Infill Touchscreen Drivers

      As I said, everything works - I can even use the volume buttons on the panel to controll centrafuse - just that the radio and the lcd controls (tilt, brightness) and the installation of infillstation won't work at all!

      Comment


      • #4
        The store cannot help you with installing other software. I'm moving this thread out of the Mp3Car forum and into the General Hardware forum.
        Jan Bennett
        FS: VW MKIV Bezel for 8" Lilliput - 95% Finished

        Please post on the forums! Chances are, someone else has or will have the same questions as you!

        Comment


        • #5
          Thanks - honest mistake!

          Still hopefully someone can help me :-(

          -Ray

          Comment


          • #6
            No harm, no foul.

            There are a number of users on here with G4s and different front-ends other than the G4. I'd suggest trying a search for some more info and other users who have the G4 who might be able to help.
            Jan Bennett
            FS: VW MKIV Bezel for 8" Lilliput - 95% Finished

            Please post on the forums! Chances are, someone else has or will have the same questions as you!

            Comment


            • #7
              Did you try the drivers that came with the cd?
              I have a G4 not bought from Mp3car that works just fine, all drivers are installed and i'm running centrafuse.

              Comment


              • #8
                Hi,

                yeah I've installed exactly the drivers that were on the CD, and as I said everything seems to be installed correctly.

                I downloaded the drivers from cartft.com

                Which version of the infill_icu drivers do you have ?

                kind regards,

                Ray

                Comment


                • #9
                  Hi Ray,
                  same problem for me. Very disappointing !
                  It seems we are not the only one.
                  Look at CarTFT, there should be an update within 1 or 2 days from now on.

                  It looks like something has changed in the G4. Don't know more yet.
                  But this is true :
                  * Infill Station do not install
                  * Streetdeck demo face quite a lot of error messages.
                  * Centrafuse do not recognize the radio and buttons. Except the volume and mute

                  As a remark, I've tried with French and English Windows XP SP2 pro and also Home edition.

                  Regards
                  Alain

                  Comment


                  • #10
                    Well Centrafuse and INFILL Station have reacted.
                    Both they have now a full support of the new G4.
                    It seems they simply recompiled using the MAXAN SDK.

                    When will streedeck react?
                    Replying that we did not buy a streetdeck and a G4 from their store is simply too easy !

                    Comment


                    • #11
                      the problem is hardware.

                      Comment

                      Working...
                      X