Announcement

Collapse
No announcement yet.

Bootstrap selection

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bootstrap selection

    I have an EPIA 5000 mini-itx with an Eden processor at 533 mhz, and 256 mb RAM.

    I have a problem but I cannot find anyone to help me.

    During the first bootup process, I hit <esc> and choose option "4" in the menu (bootstrap menu);

    This option avoids the DHCP look up. If I manually power off the unit, the unit skips the DHCP lookup, and continues loading the Fendora software.

    However, when I software reboot the unit with a linux command shutdown, the unit skips my chosen selection and does a DHCP lookup.

    Does anyone know how to solve this?

    Thanks ( Mini-itx board)

  • #2
    That should be in the bios, under boot order?
    06 Silverado LBZ wants onboard everything...

    Comment


    • #3
      Originally posted by CwF View Post
      That should be in the bios, under boot order?
      I can't find anything to set in the CMOS bios.
      I hit "esc" and I get the following screen:
      Bootstrap Selection Menu
      1. Local drives boot
      2. Try local drives boot first, then network
      3. Try network boot first, then local drivers
      4. Boot according to BIOS setting
      Press 1,2,3,4

      Comment


      • #4
        Now, I chose option 4.
        When I remove the plug, the computer turns off. I apply power and it boots up and skips the DHCP lookup.
        However, when after it booted up, I go to the root prompt and software re-start the computer (e.g. shutdown -r now). During the software boot-up, it goes to a screen and starts a DHCP lookup in which one of my system causes to freeze. I want to disable the DHCP completely.

        Comment


        • #5
          epia 5000 manual

          Not sure if that is the right manual for you or not.

          I have not yet messed with any Epia systems, or Via boards, but I am planning to soon, which is why I saw this post.

          At the risk of being completely wrong though, I'll post a few things that are fairly standard with the computers I AM used to (AMD, Intel, and most often, Via chipsets.)

          First off- don't hit "esc"- that probably just lets you select what to boot from THAT ONE TIME. You want to go right INTO the CMOS settings. Most commonly, this is done by pressing the "delete" key when the computer is starting up, although sometimes it may may other keys like F1, ALT+F1, etc. ( times out of 10, it is "delete".

          The link on top of this post is A manual for Epia 5000- may or may not be the one you have, but even if it is not exactly the same, it should give you an idea of where to find the settings you want.

          No idea if this will help you, or it may be completely wrong for an Epia system, but hey- I tried.

          Comment


          • #6
            I cannot see anything in the BIOS that disables the DHCP lookup.

            Comment


            • #7
              It most likely will NOT say DHCP lookup, actually.

              The most common entries are probably "PXE", "PXE Boot", or "Boot from Network."

              Any entry for bootup devices that you are NOT using should be disabled.
              Most likely you are just booting from a hard drive, as is most common. You should be able to set that as the FIRST Boot Device, and probably have a setting for "Boot from other device", which you can disable unless you need it.

              Comment


              • #8
                I was just looking at a few things elsewhere and found this possibly helpful info-
                Why does my VIA EPIA board give a PXE error message when I start the system?

                This is caused by the LAN Boot ROM. The network interface on the VIA EPIA mainboards has built-in Boot ROM support. By default the BIOS setting for the LAN BOOT ROM is enabled, causing the mainboard to try booting from the network.

                To avoid this message (and speed up your boot process) just set the LAN BOOT ROM to "disabled" in the BIOS (under Integrated Peripherals).

                Comment


                • #9
                  I am in CMOS Setup Utility
                  First boot Device [HDD-0]
                  Second... [disabled]
                  Third... [disabled]
                  Boot other device [disabled]

                  Comment


                  • #10
                    "the LAN BOOT ROM to "disabled" in the BIOS (under Integrated Peripherals)" This feature is not available in the BIOS.

                    Comment


                    • #11
                      I thinK I have an old version for the BIOS. Can anyone tell me where to get a BIOS update?

                      Comment


                      • #12
                        What if you disable your NIC's altogether? I would see what that does first. I have a via chipset and if I remember correctly my network card has 2 settings under integrated peripherals and its the second one that disables that dhcp function. I did see earlier that you have the boot to lan rom or whatever disabled so I would look at disabling everything and see what that does.

                        Comment

                        Working...
                        X