Announcement

Collapse
No announcement yet.

Serial Port issues, can someone help?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Serial Port issues, can someone help?

    I just got done doing a reinstall of Windows. I am now installing all the devices back in, but I am having major issues with my serial ports. I attach XM, HD Radio, OBD scanner, and AMPCTRL, which are all serial and they work off and on, but most of the time they dont. Maybe i have to flash my MoBo? When I connect XM it installs as a serial mouse, so I go to device manager and disable it, then restart and XM should work, but it does nothing. HD does the same also installs as a serial mouse which is disabled. I then go to Mitch's app and open it and it says no radio detected, but I hear the radio clicking. The OBD just seems to work when ever. The AMPCTRL seems to work perfectly though.
    Nirwana Project, the Android/Win 7 hybrid system!

    1X Ainol Novo Flame Tab
    4X MK808b
    3x Perixx Touchpads
    3x 7 inch Screens
    1X 7 inch motorized Screen
    1x Win 7 PC

  • #2
    You have 4 independant serial ports? Maybe time for a USB switchover...
    Fusion Brain Version 6 Released!
    1.9in x 2.9in -- 47mm x 73mm
    30 Digital Outputs -- Directly drive a relay
    15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
    Buy now in the MP3Car.com Store

    Comment


    • #3
      Originally posted by 2k1Toaster View Post
      You have 4 independant serial ports? Maybe time for a USB switchover...
      I dont know if they are independant.... There are 2 in the back of the MoBo, then 2 on the motherboard via header connectors. It doesnt make sense why they worked before the restore and now I have issues.

      PS: I did replace my USB PCI card with a new one, but that wouldnt cause issues would it?
      Nirwana Project, the Android/Win 7 hybrid system!

      1X Ainol Novo Flame Tab
      4X MK808b
      3x Perixx Touchpads
      3x 7 inch Screens
      1X 7 inch motorized Screen
      1x Win 7 PC

      Comment


      • #4
        check the COM-number of them in device manager. when my USB GPS went automatically to COM15-20, the sw's are unable to connect it - i could select this number, but did not work. when i set it under 10, then it worked...
        "case": Skoda Superb Elegance 1.8T
        Asrock G41MH-GE, E2180 2GHz dualcore, 1024MB DDR2/800, Samsung F1 750GB/7200RPM/32MB, M4-ATX, Lilliput FA1011 HDMI touchscreen, ASUS Xonar DG PCI, homemade Quectel L10 USB GPS

        Comment


        • #5
          I think this may be happening to me also. I uninstalled all the serial ports then unplugged all devices that use a com port. i then restarted and it installs the serial ports back to their original number, which is 1-4. I then tested with HD and XM, and it worked. So I then changed HD to 15, XM to 20 and left the OBD2 scanner at 3. All worked perfectly. I then decided to change it from 3 to 15 and all my headaches started again. So now i have to uninstall that one serial port then leave it at 3. Thing is my BT stack is also on 3 so i will just have to uninstall that.... and reinstall.
          Nirwana Project, the Android/Win 7 hybrid system!

          1X Ainol Novo Flame Tab
          4X MK808b
          3x Perixx Touchpads
          3x 7 inch Screens
          1X 7 inch motorized Screen
          1x Win 7 PC

          Comment

          Working...
          X