Announcement

Collapse
No announcement yet.

HD Radio reception woes...Any ideas?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • HD Radio reception woes...Any ideas?

    I have been trying to find a suitable radio replacement for the CarPC for a while and decided to get the HDRadio (Visteon HDZ300 HD Radio) using Mitch's cable. I'm using Centrafuse for the front end.

    Below are the specifics of how the device is connected:

    * I'm connecting the device to my onboard sound card line in.
    * Mitch's cable connected to serial port.
    * External sound card is being used for audio out to amps, then to speakers.
    * HD Radio device Ground/Power/Ignition is all being provided from the M2-ATX.
    * Device is connected to the OEM antenna and the antenna is being provided 12v for the amplification to work.
    * HDRadio device is located about 1' from CarPC.

    At the most I am only able to get one good station. The HD signal locks and stays solid for this station, but the sound still sounds really bad. It sounds scratchy and not clear. Most all other stations to don't get a lock and they sound horrible.

    Yesterday to test the antenna I disconnected with the radio on and I noticed that the HD lock went away and it just started blinking, so I know it's working.

    Does anyone have any ideas? I don't see why it sounds so bad even though it has and HD signal locked and the other stations sound so bad without the HD singal. I bought this because I heard great success stories of others but I'm getting to the point of quiting. Any help will be appreciated. Thanks.

  • #2
    try a different antenna... and make sure your computer is not causing the interference... Thats really all you can do. I have the same issue
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

    Comment


    • #3
      Which other antenna can I use?

      The weird thing is that even if the HD is locked, it still sounds bad. The other stations just sound really bad no matter what.

      Would there be a way to connect a regular head unit while having the computer connected via amps?

      Comment


      • #4
        Originally posted by fabworks View Post
        I have been trying to find a suitable radio replacement for the CarPC for a while and decided to get the HDRadio (Visteon HDZ300 HD Radio) using Mitch's cable. I'm using Centrafuse for the front end.

        Below are the specifics of how the device is connected:

        * I'm connecting the device to my onboard sound card line in.
        * Mitch's cable connected to serial port.
        * External sound card is being used for audio out to amps, then to speakers.
        * HD Radio device Ground/Power/Ignition is all being provided from the M2-ATX.
        * Device is connected to the OEM antenna and the antenna is being provided 12v for the amplification to work.
        * HDRadio device is located about 1' from CarPC.

        At the most I am only able to get one good station. The HD signal locks and stays solid for this station, but the sound still sounds really bad. It sounds scratchy and not clear. Most all other stations to don't get a lock and they sound horrible.

        Yesterday to test the antenna I disconnected with the radio on and I noticed that the HD lock went away and it just started blinking, so I know it's working.

        Does anyone have any ideas? I don't see why it sounds so bad even though it has and HD signal locked and the other stations sound so bad without the HD singal. I bought this because I heard great success stories of others but I'm getting to the point of quiting. Any help will be appreciated. Thanks.
        Nothing you can do - the HD signals are only 1/100th the power levels of the main analog channels. Sorry, another one gets duped by iBiquity:

        http://hdradiofarce.blogspot.com

        Comment


        • #5
          I'm starting to think that this whole HDRadio is just a hype and a way to sell cables

          It does not even come close to regular radio. I don't know how people are saying that it's great.

          I'm going to be removing it and selling the damm thing. What a waste of time.

          Comment


          • #6
            HD Radio works very well on my car. As sonicxtacy02 already pointed out, look into a better antenna as this varies greatly between automobiles.

            My HD Radio box is about 3-4 feet away from my carpc and enclosed inside an aluminum Mo-Co-So case, not sure if aluminum absorbs any potential noise.

            Comment


            • #7
              Does "works well" mean the same or better of an aftermarket/oem radio? Os is it below the quality of such?

              I think that the perfect solution for radio would be to just have an internet connection and listen to radio over the web. Most radio stations broadcast over the web and the quality is perfect.

              Comment


              • #8
                Are the RCA plugs grounded to the chassis?

                Comment


                • #9
                  Are the RCA plugs grounded to the chassis?
                  Are u talking about the mod posted on Mitch's site? I did, but according to his mod, only one RCA is grounded. Doing that mod actually created a ground loop as stated by other users.

                  Comment


                  • #10
                    My HD Radio quality is the same as OEM Radio. I didn't perform any ground mod on the unit at all as the audio quality is excellent. My carpc setup already has a ground loop isolator on the amp so that may eliminate the need for the ground mod.

                    Comment

                    Working...
                    X