Announcement

Collapse
No announcement yet.

Constant output from steering wheel controls! (Carbuttons)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Constant output from steering wheel controls! (Carbuttons)

    I dunno what's going on, but when I hook up Carbuttons, and test it on NotePad, it's constantly sending a steady stream of characters to Windows...
    So I can only assume there is a signal coming from the steering wheel buttons, even when they aren't in use...
    Ford Focus SVT BTW...

    Anyone else have similar issues?

    Adjusting the 'pots' has no effect also...

  • #2
    It looks like it uses some kind of variable resistor divider and you have it setup wrong. You'll have to get out the DMM and figure out what the resistance is for the controls and what the pots should be set to.

    Comment


    • #3
      I can confirm with my meter, there is resistored continuity with no buttons pressed. But why? lol
      I need to go thru the harness and double check everything...maybe a bad ground??

      Comment


      • #4
        Check voltage too, unless it's made to work with 12V

        It could have a resistance when no buttons are pressed. They all work differently. Way to go standards.

        Comment


        • #5
          Even if it does, I don't think there is anyway to filter it out, is there? I know for a fact that it's a resistive setup...
          Weird...

          Comment


          • #6
            Wow, wish he still had the schematic somewhere. If it's a 5V setup it's probably not good to have 12V going into it, but looks like it should be ok.

            The main thing is make sure you've got 2 wires that you can measure different resistances on. Write down the highest and lowest. Test each one against ground for volts then continuity. If one is ground, connect that to ground on the device. The other one probably woudn't be powered. He says to set the pot on that channel to around 5K. If it's all the way up or down, it most likely won't work.

            Comment


            • #7
              Thanks...I'll mess around with it some more tomorrow...

              Comment


              • #8
                You should be able to trace where that input goes through the pot and into an ADC pin on the PIC and monitor that. The PIC is sampling voltage from 0 to 5V and converting it to a usable number. The pot is possibly taking 0 to 12V and stepping it down, but if not maybe it's supplying 5V. But if it is 12 say you're seeing 0, 3, 4, 7, 9, 11V on the input with different buttons including no buttons pressed, you should adjust that pot so that the highest voltage button reads the closest to 5V on the pin of the PIC. Doing that should give you the most stable reading.

                Comment

                Working...
                X