Announcement

Collapse
No announcement yet.

My Solid-State Drive + Windows 7 Experience

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • My Solid-State Drive + Windows 7 Experience

    I decided to take the plunge and buy a $175/60gb solid-state drive [ssd] and reformat my carpc with windows 7. I haven't read much about either topic here so I figured I'd share my experience thus far.

    Windows 7:

    It's only been a few days but so far the experience has been nothing short of great. Windows 7's new update manager concerning codecs/drivers is really smart and can help you find usually any missing codecs/drivers that you may have lost the CDs for. It wont help you find obscure ones like for your touch monitor but most of the motherboard/sound/wifi/ethernet ones it found right away. I did have one issue where it would install an obscure audio driver and would freeze during a reboot, but system restoring to a few minutes earlier, and deselecting that driver to install fixes that problem.

    One great thing I've noticed, so far, is that 7 doesnt seem to drop the port number for plugged in USB devices when it resumes from hibernate [ GPS and OBD], so Xport doesn't seem to be necessary and plugging in more than one USB device won't be an issue for some [as it has in the past]. Don't hold me to that, but it hasnt dropped the port # yet in the past few days. Oh and going into resume and coming out of it seems a bit faster too but this may be the SSD helping it.

    The speed overall is comparable to XP, that is to say WAY faster than Vista and a lot nicer to look at. I'm actually using the 64bit version on my home PC and all-in-all it's definitely worth getting this OS if you're looking to upgrade from XP and you better do it if you have Vista.

    SSD:

    On paper, the SSD's, compared to traditional HDD's, are about 50 times faster. [Think 2mbs read time to 100mbs read time] however in practice this will never hold up. With only a few days of testing under my belt, and no real knowledge of how to bench mark, I have to say it is maybe 2-3x as fast as the older HDD's I had [7200 and 10000 rpms] Boot times have definitely been shortened and scanning of the library, moving files, etc is faster. $175 for 60gb faster? I dont know about that- I would wait till the holidays to pick one up, by then the prices will have dropped to be a little more reasonable.

    One of the biggest things I am happy about is that, in the Florida heat, mid day, under my trunk liner- this drive wont overheat and freeze the system which would happen almost 100% of the time with the old drive. Thats a HUGE plus for me and almost makes the money sink worth it. The drive itself is extremely light too - almost feels cheap after feeling old heavy clunkers of harddrives all my life.

    So that's about all I got so far. For anyone who is wondering the machine itself was one from mo-co-so.com with a Centrafuse frontend. If anyone has any questions, feel free to ask.
    My CarPC

  • #2
    What are your hardware specs and what are your boot times looking like so far?

    Comment


    • #3
      Any hibernation time comparisons between XP and Win 7?

      Comment


      • #4
        MachineHead - I dont know exactly but IIRC, I have a pentium D 1.3 and 1GB ram in my machine. Boot times seem about equal, perhaps a little faster to XP but I had been using an optimized XP edition compared to an out of the box W7 version- so perhaps if someone releases a stripped down version of W7, boot times will increase.

        nobb: W7 doesnt have a status bar for the hibernation like XP did, but i would say hibernation times are cut in half both going into and coming out of. Id say anywhere from 30 to 45 seconds in xp to 15-25 in 7. In XP it took another 20 seconds or so to dismount and mount the USB devices [touch screen, gps] after coming back from hibernation but it seems W7, with the SSD, does it right away, within a few seconds.
        My CarPC

        Comment


        • #5
          Hibernation times cut in half? Wow that sounds too good to be true. I would upgrade to Win7 just for that...but Im not sure if maybe I should wait until it is officially released and maybe some of the potential bugs ironed out.

          Have you noticed any incompatibilities with Win7, maybe with your frontend or devices? Im a bit of a newbie with this, but for most devices which do not have a special Win7 version of the drivers, do you just install the XP or Vista version?

          Comment


          • #6
            hibernation is much faster on win7 than xp on my new setup (but i took it out because i couldn't get sound card to work properly), but was about the same for my old setup.
            Will definitely give win7 a try again when the retail comes out.

            Comment


            • #7
              nobb: well im using W7 WITH a solid-state drive. so im assuming its both that contribute to the cut down times.

              Whats great about W7 is that, unlike vista, everything seems to be compatible. Ive been installing XP and vista drivers for most things and they all took first try. and for what i didnt have drivers for, W7 found them for me automatically. i was incredibly surprised it did this and did it effectively.
              My CarPC

              Comment


              • #8
                here is the screen close up



                here is the whole dash



                here is the machine under the trunk liner.

                the black sleeve carries most of the wires for the screen/power/USB cables and the mess off to the right is the audio cables and gps. its a little messy, especially with the soft cushy casing i had to build on account of ruining the original cubby casing, but its all hidden once the flap is down. im sure it would still make a professional installer queezy.


                My CarPC

                Comment


                • #9
                  The screen mount looks nice and clean. Considering that's the only part you can actually see, that's all that matters. The wiring on my system isn't all that clean either, especially under the driver seat.

                  I've been running W7 since RC on my desktop and I love it. I've been waiting on put it on my CarPC because my setup works fine as is with XP. The only thing that bothers me is the boot time which is about a 45 second cold boot. Hibernate in XP causes all sorts of issues, so I've been eyeballing the hybrid sleep mode in W7.

                  Comment


                  • #10
                    What do you mean issues? Mine would freeze during hibernation sometimes. that's incredibly frustrating. I was close to installing a hard reset button in the dash somewhere just for things like that.
                    My CarPC

                    Comment


                    • #11
                      It's been a while since I tried to hibernate but if I remember correctly my sound card wouldn't work correctly after hibernating. I also had issues with my screen doing strange things and my USB devices wouldn't always come back.

                      Edit: Also I have the problem that M-Audio hasn't released any Windows 7 drivers for my soundcard. They were 6+ months behind on drivers compatible with XP SP 3, so I'm not surprised.

                      Double Edit: Amazingly M-Audio has beta drivers out.

                      Comment


                      • #12
                        If the cold boot time on W7 would match the cold boot time I'm getting with XP...I'd be all over it. Right now from post to front-end is 12 seconds. Believe it or not, hibernation/resume takes longer. I'm using a Patriot WarpV2 32GB SSD and EWF.

                        super clean install though. Love it

                        Comment


                        • #13
                          unless you have very few startup processes/incredibly optimized system, i dont see how thats possible from a cold boot.

                          ...if it is. id like some pointers
                          My CarPC

                          Comment


                          • #14
                            your usb hibernation issue could be fixed by xport.

                            My xp system currently could cold boot almost as fast as hibernation. The status bar is done the moment you see it. The only issue is centrafuse takes too long to start from cold boot compared to hibernation + stupid nag screen. Hence I'm using hibernation. For my cold boot time, I've done very many optimization. Which includes turning off almost everything that is unneed in bios, turn off about 3/4 of my already optimized winxp services (tinyXP). Turning on multicore boot, and maximize the memory on boot time. My biggest issue is that my system is resuming from 2gb of ram as supposed to my old 512Mb, where i'm finally seeing the difference between memory installed.

                            Comment


                            • #15
                              you can turn off the nag screen in CF by adding -nolimit -nowarning to the shurtcut extension.
                              My CarPC

                              Comment

                              Working...
                              X