No announcement yet.

Silabs USB FM Radio doesn't work

  • Filter
  • Time
  • Show
Clear All
new posts

  • Silabs USB FM Radio doesn't work

    I've bought a USB radio FM (
    Yesterday I try it on my computer (with Windows XP SP3 installed); following the instructions, I've plugged the radio in a USB port; windows installed the driver, apparently in the right way; then I downloaded the program from the above link; I run usbradio.exe, I set up the correct parameter for my country (Italy, then settings for Europe). Now, the frequency is locked to 189.80 MHz (that, I suppose, is outside the range of FM radio). Now, when I try a manual or automatic search of frequency, in a matter of a few seconds, it returns to the 189.80 MHz frequency.
    I've tried the USB radio on my brother's laptop, and it behaves in the same way. This morning I've tried also on my work's computer, but with no results: it is stuck on 189.80 MHz.
    Have you some ideas on what I should do to make the usb radio work?
    Thanks in advance for the answer.

  • #2
    Hi TaNdOi,

    Perhaps try another regeon first and get the tuning out from where it is stuck?

    Else, use one of the preset frequencies to tune it our from there?

    I have a total different problem with mine.

    I had to plug it in a few times before it was recognised and then I had zero reception, just static all over. Although my Nokia N95 had perfect stereo reception in the same spot the Silabs got nothing, just static. It would tune wherever I wanted it to but just static, nothing else.

    I then try it on my laptop but it won't see the device, not in any USB plug. Tried my Carpc Gigabyte and also not luck at all.
    Now I tried it back on my desktop and it does not work here either, no responce!

    Logged a query with Silabs but I see from many other mails that won't be answered!

    Anyone else have any of these problems?

    I searched for a few products and desided on the Silabs due to the good reviews, but now desaster


    • #3
      Just an update,

      I returned the unit (takes 3 weeks here in Africa)

      So, now it works as advertised.

      But, now I can't get any RDS info from it! Neither using the Silabs radio or under CF3.0.

      Do I need to enable something or change some settings?