Announcement

Collapse
No announcement yet.

USB Sound and Bus powered hub

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • USB Sound and Bus powered hub

    All right guys I pulled most of my gear out of my main car (87 Supra) and dumped it (quite literally) into my 91 Celica due to the Supra's ongoing rebuild. Since the dump I've developed a new problem with my USB sound card, which is plugged into a bus-powered hub along with my wireless, mouse and char LCD. The problem is that whenever I use the mouse, or the LCD backlight changes to anything other than full on or full off I get noise through the speakers. In the Supra I had a dedicated USB extension cord for sound however I don't want to rip any wires out to get rid of a problem in a temporary setup. Has anyone used USB sound with a powered hub? If so how did it work? Any other ideas are welcome, this noise is getting aggravating.

    Thanks in advance.
    2002 Golf TDI With Phatbox . Blue 87 Supra Needs to go, Grey 89 Targa with stock Radio.

  • #2
    Can you just buy another USB extension cord? How much more length do you need? Those cords can be pretty cheap.

    I'll bet that if you ran the power seperately from the USB hub itself (i.e. run just a pair of wires back to your computer and splice into a +5V lead, or the keyboard jack, or the other USB jack) it would get rid of the noise. The sound has to get to the USB soundcard via digital means anyway, so it can't be affecting the signal wires, so it must be coming in via the power wires.

    Alternatively you could wire an inductor inline with the USB power wires (again though you'd have a splice a cable)... That might help get rid of the AC fluctuations in the power that's likely causing the noise.
    IN DEVELOPMENT -- '96 Mustang, lilliput with PII/450 laptop, custom DC-DC power supply, 60GB; Garmin GPS; 802.11g; compact keyboard, small graphical LCDs, OBDII.

    Comment


    • #3
      Yeah, I think I'll just buy another extension chord. Does anybody know if Best Buy or Circuit City sells them? I was kind of hoping for a quick fix.

      Sorry, I didn't make it clear but the hub is powered by USB no adapter.

      Thanks
      2002 Golf TDI With Phatbox . Blue 87 Supra Needs to go, Grey 89 Targa with stock Radio.

      Comment


      • #4
        Here's an easier fix!

        POWER YOUR HUB.

        The reason that is probably happening is because you're stressing the USB bus beyond the 500ma/channel that it can provide. This is bad.
        IN DEVELOPMENT -- '96 Mustang, lilliput with PII/450 laptop, custom DC-DC power supply, 60GB; Garmin GPS; 802.11g; compact keyboard, small graphical LCDs, OBDII.

        Comment


        • #5
          I believe your right.
          2002 Golf TDI With Phatbox . Blue 87 Supra Needs to go, Grey 89 Targa with stock Radio.

          Comment


          • #6
            Don't know if you have 2 (or more) USB ports on the mobo.

            If you do, plug your sound straight into the 1 port and use the other for your other accessories.

            Do check your power usage via Device Manager, and double click your USB hub and choose the power tab.

            500mA is max per port and I have a GPS and it's 500mA itself.

            -- Vikram
            5.6" Indash LCD | Sony MDX-610 HU | Sony XA-300 (USB Audio!)
            Apple iPod 30GB | Treo 600 with GPS |

            www.vikrampant.com

            Comment


            • #7
              vikrampant: The point was that what you are suggesting is what he used to do, however he doesn't have an extension cable for use in the current car so it won't reach, which is why he needs to use the hub. In his original car he has a dedicated extension cable to do exactly what you said.

              Good point about checking power consumption though. It's only a "rough" number based upon what the USB device tells the hub that it needs, not based on actual current being used, so treat it as a "max" number.

              The USB sound card probably takes the full 500mA, my corded optical mouse takes 100mA and the LCD probably uses the full 500mA as well, which means very bad to put them all off the same port without supplimental power.
              IN DEVELOPMENT -- '96 Mustang, lilliput with PII/450 laptop, custom DC-DC power supply, 60GB; Garmin GPS; 802.11g; compact keyboard, small graphical LCDs, OBDII.

              Comment


              • #8
                I got a powered USB hub for easter. I'll let you guys know know what happens.
                2002 Golf TDI With Phatbox . Blue 87 Supra Needs to go, Grey 89 Targa with stock Radio.

                Comment


                • #9
                  I'm happy to report that the noise is gone. Hopefully my parts will get here today so I don't have to drive the Celica anymore.
                  2002 Golf TDI With Phatbox . Blue 87 Supra Needs to go, Grey 89 Targa with stock Radio.

                  Comment


                  • #10
                    Originally posted by Suprapc
                    I got a powered USB hub for easter. I'll let you guys know know what happens.
                    A hub for Easter?!?!?!

                    CL...

                    -Mario

                    Comment


                    • #11
                      Yeah I got a powered USB hub instead of candy and what not.
                      2002 Golf TDI With Phatbox . Blue 87 Supra Needs to go, Grey 89 Targa with stock Radio.

                      Comment

                      Working...
                      X