Announcement

Collapse
No announcement yet.

USB Devices Disconnect

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • USB Devices Disconnect

    I have a few devices plugged into a USB hub that is on a USB extension. Sometimes these devices disconnect and it takes a system restart to get them to work again. Could this be because they are not getting enough power or because the hub is not getting enough power?


    Thanks for any help.

    By the way, devices not plugged into that hub dont have that problem. I have the other devices plugged into a hub that is plugged into an active USB extension cable and have few problems with them. Those include the USB touch screen control, USB keyboard receiver, and USB Clear Modem (occasionally disconnects from the network but could be due to motion Im guessing).
    My 2007 Jeep Wrangler Worklog

  • #2
    Check the voltage. What are you powering your USB hub from? I know I have this problem with my 7 port USB hub and M2-ATX psu. The M2 doesnt seem to be able to handle high loads on the +5v rail very well. If your USB extension is long, it could also be dropping the voltage.

    Comment


    • #3
      I think thats the problem. With that added length and it being just a generic 4 port hub with no extra power source its just too weak. I guess Ill have to save up and buy a good powered one for there.
      My 2007 Jeep Wrangler Worklog

      Comment


      • #4
        Powered hub's is ALWAYS a must. Unless your just plugging devices with their own power source.

        Comment

        Working...
        X