No announcement yet.

Hard drive upgrade problems :-(

  • Filter
  • Time
  • Show
Clear All
new posts

  • Hard drive upgrade problems :-(


    I hope someone here can help. I have a car based MStation. I purchased it with a 10GB drive (which was stupid) as I have filled it. I have swapped it out for a 20GB drive. Now the MStation wont boot (now there is a suprise.....)

    Thing is I recon it should. The new drive, just like the old one has a single FAT32 partition which has been set as an active partition. The drive is set to Master (just like the last one). I have copied over all the files (including the hidden system ones). I have even tried cloning damn drive, but to no avail.

    The only other thing I can think is one of those system files I copied over may have contained drive information, but they are not in plain text so I cannot check easily.

    If anyone has any ideas about this, I would really appreciate a pointer,


  • #2
    Did you reformat this new drive?

    You cant just copy every file over like that.
    What im curently listening to.
    My complete carpc setup


    • #3
      Ok I'll bite.

      When you stick the new drive in...can you see the drive size in the BIOS...or is this one of those systems that you have no access to the guts of the machine.

      If you can see the correct drive size, then most of your troubles are over.

      If not...then you may need to do some tweaking.

      I would recommend (if this is a normal system, and not a proprietary system) that you make one partition at 2-5 gigs or so, and the rest of the drive a second partition for storage.

      If you buy or get a copy of Ghost, you can make an exact copy of the old partition to the new drive.

      If it trys to boot but you get an error about no system found or install boot disk, then you need to set the partition as primary.



      so on


      so fourth

      If this is a proprietary system that runs on linux etc, then you will have to refer to the manufacturer for tech info.
      current projects


      • #4
        Hey Guys.

        Thanks for you help but I think I am on a looser here. I have put the original drive back in now and it works fine.

        Problem is, there is no operating system I am aware of (I am sure it runs something, but I have no access to it).

        I also tried Ghost, but that doesnt work either (which I thought was really odd).

        Oh well - I suppose 1500 songs will have to be enough.....


        • #5
          Don't give up on it yet!
          Did you try the 10 gb drive as a slave in another machine to see what's in it, to play mp3s?

          There are tricks to run other programs as shells instead of the OS, winamp comes to mind.


          • #6
            ur...You have to set up that new drive dont you?
            Format and Install Windows? or whatever?

            or you could install it as a second drive.

            just a nation of two hundred million used car salesmen with all the money we need to buy guns and no qualms about killing anybody else in the world who tries to make us uncomfortable.

            Hunter s. Thompson


            • #7
              I know you probably already did this....but did you set the other drive to MASTER? I have forgotten to do this a couple of times...


              • #8
                Make sure your new drive is set to:

                "Master", if it is the only drive on your system.
                If you install both drives on IDE1, one drive must be set to "master/slave present" (This will be your C: drive), the other drive should be set to "slave".

                If one drive is on IDE1 and the other on IDE2, both should be set to master.

                Install the new drive as above, make a startup disk from another windows system, boot from floppy disk, when at the DOS prompt
                type : A:>SYS C:<return>
                This will transfer the system files to drive C:
                If SYS.COM is not on the floppy, youl find it in the "c:\windows\command" directory.

                If it still dose not boot run Fdisk, make sure the C partition status is set to "A" Active.

                Hope this helps you.



                • #9
                  i need stereo

                  ok guys i have a question?
                  how can i get rid of the useless fm modulator unit and attach the mstation to a prewired cd autochanger system
                  its a philips ccr600 without the autochanger and is fitted into an opel zafira

                  any ideas???
                  jabberwock (no not jabba the hut )


                  • #10
                    After upgrading your mstation hard disk it is worth getting the new open-source firmware from SSI America:


                    It has support for larger hard-disks, better random functions etc...
                    Make sure you put the neo35.bin file in the root of your hard drive and follow the instructions in the FAQ to flash the firmware.

                    It is also worth getting neocheck which makes sure you are adhering to standard directory sizes etc... on your mstation drive. In saying that, you shouldn't have to upgrade the firmware to run the hard disk from your PC so I would test it outside the mstation as well.

                    Hope this helps



                    • #11

                      The Mstation is fussy about what drives it will accept, I have upgraded a couple using Samsung drives with no problems but it will not work with Hitachi IBM drives (actually kills the drives if you persist...)

                      Hope this helps