No announcement yet.

USB Sound Card Pains

  • Filter
  • Time
  • Show
Clear All
new posts

  • USB Sound Card Pains

    Hi Gang,

    I was hoping to get some troubleshooting help for an issue I am having... I recently got a Soundblaster X-Fi 5.1 USB soundcard. My initial intent was to place it in my center console which is fairly close to my amp (under the passenger seat). The device would be connected to a powered USB hub ( via a cable that is about 5' long.

    When I set this up, I noticed usb/soundcard errors being reported on my Ubuntu based system, which eventually caused my system to freeze. I also noted that the pretty blue light that was suppose to illuminate was not doing so. So using the light as my indicator of working or not -- I tried the following:

    1. So we know 5' cable from rear hub (situation above) was a failure
    2. Attached Soundcard to hub located at the front of the car via a cable of about 3' (hub is the same as the one at the rear, ie: powered) also a failure
    3. Attached Soundcard to computer in the house with short USB cable provided with the card -- pretty blue light
    4. Using the same cable (and computer) plugged Soundcard into a 1.1 hub -- pretty blue light
    5. Using the same cable as 3&4 plugged Soundcard into car computer USB port -- pretty blue light.

    While the device was plugged into my main box, I looked at the power requirements it was reporting -- and it says it needed a max of 400ma.

    So what is broken? The Soundcard failed to work with 2 different hubs using 2 different cables and worked (at this level of testing) with 2 computers, 1 external hub, and 1 short cable. Does this suggest I have bad cables (from the front & back) or that there's a problem with the hub design, or that there's a cable length maximum that the device won't work with? I was initally thinking this might be a power problem, but the lengths I am talking about are far short of what the USB spec calls for.

    I will be greatly appreciated of any help with this...

  • #2
    Sounds like a compatibility problem between that powered hub and your sound card, or the hubs are faulty, or they are wired incorrectly, or that sound card pulls more than 500mA. Do a test with a standard powered hub, and plug it into a cigar lighter power inverter. If the "pretty blue light" comes on, then you know for sure there's an issue with those hubs.

    Also, when you plug the hubs into your computer, do they show up in the device manager, and do you hear the familiar bing-bing sound when you plug them in? Do other USB devices work when plugged into those hubs?
    Last edited by kegobeer; 04-05-2011, 07:47 AM.
    1999 Mercury Grand Marquis GS with: ASRock E350M1 w/4GB RAM, 80GB Intel SSD, Opus DCX3.120, Visteon HD Radio + HDR-USB, PL-18N wifi, OBDLink Scan Tool, BTA6210 BT, BU-353, Win 7 Ultimate, CF 4.0, Alpine MRP-F240 + MRP-T220, RF Punch 1572s, Kicker 8" Comp.


    • #3

      The front and back USB hubs are 2 seperate devices (just of the same model) -- so are you suggesting the design of them is bad? They work with multiple other devices; the rear has a usb wifi adapter, a bluetooth adapter, and connects to another usb hub which has a number of devices that also work fine and the front one has the touchscreen monitor a 2nd USB hub and USB-UIRT all working fine.

      As noted; the max the device reports using is 400mA -- which I pulled from a report on my linux box. The "pretty blue light" does show up with another USB hub (using the short cable).

      Since I am using linux all around, no bing/bongs. However, on the situation that work "lsusb" shows the Soundcard correctly -- while in the senerios where the light doesn't show, I get a lot of usb related errors.


      • #4
        where are the powered hubs getting their power from?
        My OLD 2001 Mitsubishi Eclipse GT:
        "The Project That Never Ended, until it did"

        next project? subaru brz
        carpc undecided


        • #5
          They are getting power from the car battery.


          • #6
            your using something like the mp3car store powered hub? where it takes unfiltered 12v in?
            My OLD 2001 Mitsubishi Eclipse GT:
            "The Project That Never Ended, until it did"

            next project? subaru brz
            carpc undecided


            • #7

              I am using the mp3car powered hub (x2).


              • #8

                I ran one additional test, using the short cable that worked with the sound card on successful attempts I plugged it into the usb powered hub. No go. Which leaves me at kegobeer initial conclusion -- an incomparability between the hub and the sound card. So, now the question is -- which one is broke/implemented wrong?


                • #9
                  It's the hub that's got it wrong. For some reason, automotive hubs have issues with hardware when ordinary powered hubs don't. You can convert a normal powered hub to run on 12V pretty easily if you want to test out the compatibility theory.

                  There is another hub you can buy: the RAM tough USB hub.


                  I don't know if it would have the same problems, but if you decide to return the mp3car hubs, it's something else you can try out. I bought one, but it's not here yet, so I can't tell you how well it works.
                  1999 Mercury Grand Marquis GS with: ASRock E350M1 w/4GB RAM, 80GB Intel SSD, Opus DCX3.120, Visteon HD Radio + HDR-USB, PL-18N wifi, OBDLink Scan Tool, BTA6210 BT, BU-353, Win 7 Ultimate, CF 4.0, Alpine MRP-F240 + MRP-T220, RF Punch 1572s, Kicker 8" Comp.


                  • #10
                    Ran into a similar situation with a device on the front hub in an old installation, in the end I tried a quality heavy duty 15 foot USB extension cable (no data repeater no Hub) and the device worked perfectly.

                    In my new setup I ran 3 of these cables. One is connected to 2 x 4 port hubs (both unpowered at this time as I haven’t got around to connecting 12v) with 6 ports in use I have no problems at all, of course nothing requiring a recharge is in plugged in and High output USB ports on the MB help.

                    The second cable is dedicated solely to a GPS RX and third cable is spare to cover anything I can throw at the system in the future. Point is, a high quality heavy duty extension cable “MAY HELP” bring the MB USB port closer to the problem device. If everything else fails it may be an option.
                    Palm sized ainol MiniPC, 8" Transreflective PRO, Win10, Reverse camera, Dual 10HZ GPS RX's for Speed Display & Sat Nav, FM-DAB & Phone Modules, iDrive interface. T-Screen HVAC control, custom microcontrollers, microcode and FE.


                    • #11

                      I would love a review of the RAM touch hub once you get it


                      • #12
                        So I contacted the store and had them take a look at this thread... They came back and asked for some more info (as they are stumped right now). So I thought I would post things here you others can see (and maybe help) on this. Stephen asked the following:

                        "You said you're using Linux. However, are you able to bring the P5USB and sound card inside and power the P5 from an AC/DC adapter and connect it to a Windows based PC? If so, do you know if the device is recognized by the device manager when you do this?"

                        1st off, I don't have a windoze box (per se). But I do have WinXP running under Virtualbox. I went back and checked to make sure the card is seen by linux via the 1.1 usb hub connected to my main box. I've uploaded a file called "usbstuff.txt" that has the output from 'lsusb -v' -- you can see all the specs for devices connected to my main box via usb (this one has the creative soundcard attached). BTW: windows under virtualbox does see and load the soundcard.

                        2nd: So I wire up 12V power to pass to the P5 from an AC/DC source. The file usbstuff2.txt is the 'lsusb -v' output for the sound card connected to the p5 which is connected to my main box. In this configuration I can't pass the sound card through virtualbox to winxp at all. BTW: the cable is the same cable used for the 1st test in this post.

                        Man, is this going to make me

                        BTW: I was also asked what motherboard I am using -- it's a ibase mb899 (one I bought from mp3car a long time a go)
                        Attached Files
                        Last edited by nasa; 04-09-2011, 06:53 AM.


                        • #13
                          Upon further review,

                          I've noticed that the sound card connects for some very short period of time and then disconnects (only when connected via the P5). The short time period is measured in seconds (maybe as much as a minute).


                          • #14
                            So I tried something out -- just to see what happened... I plugged the working usb hub into a port of the questionable usb hub and plugged the sound card into the known good usb hub, ie:

                            -> Good hub
                            -> Sound card

                            Resulted in Linux seeing the sound card, no drops, and WinXP (out of Virtualbox) having the device show up (as working) in device manger.


                            • #15
                              Haha awesome ^^^
                              Don't we just loving doing things that are different..