No announcement yet.

GPS acting as mouse... sometimes

  • Filter
  • Time
  • Show
Clear All
new posts

  • GPS acting as mouse... sometimes

    I know this have been up before, but the solution I found didn't fit to me.

    I have a BU-303 and sometimes (maybe 1 of 30) It (or something) freaks out and starts moving the pointer clicking everywhere.
    I read it was just to disable the "mouse", But I don't have any mouse except for the touchscreen in the device manager.

    I have tried to search for this specific problem, but it was hard to find.

    Can anyone help me?

  • #2
    try resintalling the drivers for the gps unit, and also make sure you have the most up to date drivers. it sounds like there is a conflict betweeen the touch screen and the gps. Are they both USB?


    • #3
      This could be the infamous MS Serial Mouse problem. Sometimes Windows will whack-out and think the GPS is an MS Serial Mouse. To fix it, there is a registry hack that eliminates the MS Serial Mouse (so I hope you don't use one!).

      Check this fix out. It's for the Deluo GPS, but I'm betting that it will work for just about any GPS with this problem.


      P.S. This is for Win2000 and XP only.
      Attached Files
      So far:
      M10000 Nehemiah, 1Gb RAM, Opus 90w PS, Buffalo Tech WLI2-USB2-G54, 160 Gb HDD, GlobalSat BU-353 GPS, iGuidance, Zippy EL-610, Panasonic CW8123B Slim Slot CDRW/DVD, 10" Lilliput, Sony XA-300, Sony CDX-MP30 Head, OBD-II


      • #4
        I'll try that
        I also think it has something to do with the serial mouse problem.


        • #5
          Serial Mouse

          During windows booting it reconize Mouse's installed on the serial ports.
          There is an option to disable it in the boot.ini file.

          Check Microsoft Knowledge Base Article - 131976 :

          i hope it will help, becasue what you are describing is that there is no other mouse's reconized except the touchscreen driver.


          • #6
            No I don't have any mouse installed more than the touch.
            Sometimes when I configure the carputer I use a PS/2 mouse.
            never a serial


            • #7
              Find the "mouse" in Hardware manager and disable it. Problem solved.

              The GPS will still work fine after that.
              Aura MR62 (F and R)
              My Current MP3s


              • #8
                Yeah that's what I tried first, but as I said in my first post. The only mouse is the touchscreen. So there is no mouse to disable.
                Maybe there is one when the problem occurs, but then I can't do anything with the computer because it goes crazy (clicking and draging everywhere)



                • #9
                  When your computer starts going crazy unplug the GPS. The Crazyness will stop then go to the Hardware Management.
                  Aura MR62 (F and R)
                  My Current MP3s


                  • #10
                    Weird...I always thought it was the connectors problem for my Xenarc...

                    I know what problem you're talking about... It's when the mouse constantly right-clicking all over the screen...moving windows and stuff...

                    My touchscreen is Serial and I do have a USB GPS...But I never touch my GPS only unplug and plug the connectors for the Video/Touchscreen plug on my Xenarc


                    • #11
                      I have the same problem. I ran the Deluo mouse fix but it didn't help. The problem happens more often when I have more cables plugged into the MB. I also have a 6’ extension cable plugged between the Deluo’s USB connector box and the GPS. I’m going to try replacing the wiring with a heaver gage, better shielded cable. But that won’t happen for a few weeks. Is anybody else using an extension cable on there GPS and having this problem?


                      • #12
                        I ran the deluo mouse fix off of the CD, (basically a reg file) and it worked great.

                        Here is the actual support info from Deluo, if this doesnt help then I dont know what will:


                        • #13
                          Yup just disable the GPS appearing as mouse in device manager. Its called something like MS ball mouse...cant remember now.


                          • #14
                            disabling drivers don't help, nor does the /NOSERIALMICE option in boot.ini... the only fix is the above mentinoed registry hack.


                            • #15
                              for me anyway