Announcement

Collapse
No announcement yet.

Laptop HD issue...??

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Laptop HD issue...??

    Ok so I bought a used 10gb 2.5" HD for one of my itx systems (in home media player), however I cant seem to get access to the HD.

    I get one of 2 errors, either that the HD is locked, or ewhen i use IBMs HD utilities it says that its password protected.??

    Any ideas how to get it to let me format/ install my OS? I dont have the laptop it came from, nor do I have/know the password....


    Any help would be appreciated
    Apolo
    2002 DSM RSX-S
    Custom Car PC Re-design Pending Completion of fiberglassing dash and trunk
    Pics

  • #2
    Sounds like you might have bought it from somebody that yanked it out of a ThinkPad that had the Hard Drive password enabled. Some of those passwords are stored in the chip on the harddrive and may be hard to remove. Are you able to FDISK or FORMAT it?
    1.6GHz HP e-PC, 768MB RAM, 120GB WD HDD, Slim DVD-ROM, Onboard sound & video, 7" Lilliput, USB GPS Mouse, Audiovox FM Modulator, Vector 400 Watt Power Inverter, Windows XP Pro SP2, iGuidance 2, 15" Samsung LCD for the rear *Carputer not installed*

    Comment


    • #3
      ConfigMagic

      ApoloV try using the app ConfigMagic. It is used for unlocking and locking xbox hard drives, but should work for any hd.

      Comment


      • #4
        I once had an old 486 motherboard that could do formats right from the BIOS. I've never seen it on any other motherboard till this day. The cool thing is, if DOS wouldn't format it, the bios still would. Ahh the good old days where they actually did something useful with the bios...

        Course, this doesn't help you at all I suppose, unless you could find one of those motherboards. I say take the drive back and if they whine about a no return policy talk to the manager, then the owner, chamber of commerce. Unless the thing was tagged as is they shouldn't be selling stuff that doesn't work.

        Comment


        • #5
          Thanks guys, but I'm still having issues.. DOS doesnt recognize the drive so i cant format or fdisk.

          Looked for ConfigMagic and found some Xbox tools but they all require for me to know what the password is.. Thats my issues I dont know what it is..

          And Adamis when i say bought, it was from a friend for a some help i gave him before. He's not a hardware person and was gonna throw it out, so I thought i'd give it a try...

          Any other suggestions guys?? Are there any bruteforce ways to unlock it so I can use it w/ my home itx pc? I wish i had a PC w/ functional BIOS for formating, all I have around me is 2 itx systems and this XP machine

          Getting this workin would be wesom so let the ideas roll...

          Apolo V
          2002 DSM RSX-S
          Custom Car PC Re-design Pending Completion of fiberglassing dash and trunk
          Pics

          Comment


          • #6
            I am not completely sure on this one, but if fdisk has no knowledge of a Device (hard drive(s)) then bios must not be recognizing it.
            Mark

            Website: http://www.greenpowerenthusiast.com/

            Car'Puter Project
            - Xenarc 700TSV
            - MSI RS482M-IL Mobo + AMD Turion MT-32 (25W)
            - 1x 256MB Corsair XMMS DDR400
            - M2-ATX
            - Belkin 802.11G W-Nic
            - Garmin 15H GPS
            - WinXP SP2 (NLited)

            Comment


            • #7
              The BIOS recognizes it. And IBMs HD Utilities, and the Xbox HD utilities see it too.. But they cant access the drive. If I knew the password I could type it in using the Xbox utils, but i dont. I actually googled this issues and it starting to look like a dead end on my part as IBM laptops are notorious for having HDD locks that cant be hacked unless you send the drive to IBM.

              I'm willing to try almost anythig since its not like I'd be losing $ or data if the drives ends up being scrapped...

              Thoughts?
              Apolo
              2002 DSM RSX-S
              Custom Car PC Re-design Pending Completion of fiberglassing dash and trunk
              Pics

              Comment


              • #8
                i just tried to install my IBM laptop hd today and the comp doesn't even detect it at all.. any help please???
                http://www.hostunlim.com/kamlung/Cars//TL/sigfinal.jpg

                Comment


                • #9
                  AFAIK nobody has been able to crack the password protection on IBM laptop hard drives. Unless you can track down the owner, I'm afraid you are hosed.

                  Comment


                  • #10
                    which Dos and fdisk are you trying?
                    Dos may not recognize it, but did you actually run fdisk and what did it do?
                    fdisk not see it at all, or see it but not recognize it,
                    or fdisk see it but just not able to do anything with it?
                    Dos won't recognize NTFS disks or Linux disks, too, but fdisk can still see them,
                    and can still work on them.

                    I have a dos program called gdisk that might work, that's much better than dos's fdisk.
                    It came with Symantec's Norton Ghost v6, on a floppy.

                    Comment


                    • #11
                      i tried to load with a win 98 boot disk... i ran fdisk and it said that no drive attached... i will try again tomm and post the exact result..
                      http://www.hostunlim.com/kamlung/Cars//TL/sigfinal.jpg

                      Comment


                      • #12
                        Use diskedit from Norton Utilities, it can connect to physical disks.
                        Chrysler 300 - Fabricating
                        http://hallert.net/

                        Comment


                        • #13
                          @kamlung
                          you have to get the computer's bios to see and recognize the drive, first.

                          Comment

                          Working...
                          X