Announcement

Collapse
No announcement yet.

i think my ITPS isnt working...

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • i think my ITPS isnt working...

    im running the 200w ps with the ITPS. Earlier in the day i plugged everything in my car and it powered up. So then i took it out and back inside the house to install windows and all of that on it. After that, i put it back in the car, and it wouldnt power up anymore.

    I know its not the power supply's problem because i hooked that up directly to my battery and it worked fine. Then i tried hooking the ITPS to the battery and it wouldnt turn on.

    My conclusion is that the ITPS just died. I read somewhere that if the ground wire touched the heatsink, it would **** it up, so im thinking that might have been what happened... but i dunno...

    any thoughts?

    Should i just send the ps and itps back to the store and get an opus? but the thing is... is the opus powerful enough to power a 1.7ghz p4 on a via epia mini itx P4 mobo with a 3.5" drive (maybe two 3.5" drives)??

    TIA
    http://card.mygamercard.net/gbar/car...theberetta.gif

  • #2
    The ITPS power regulator can only handle up to 60W - if you want to use it above that power level then you'll need to bypass the regulator, which kind of defies alot of the point of the ITPS in a way.

    It's problems like this that made me try out the OPUS PSU's and I haven't even thought about going back to anything else since

    As for the power requirements of your system - I'm not really sure, I think you'd need the 150W OPUS to do the job but I'll let someone more knowledgeable answer that question.

    HTH,

    Andy

    Comment

    Working...
    X