No announcement yet.

IBM T42: disable onboard speakers and microphone using port replicator II

  • Filter
  • Time
  • Show
Clear All
new posts

  • IBM T42: disable onboard speakers and microphone using port replicator II

    does anyone know how to disable both? the PC speakers remain on when I plug in a set of speakers into the port replicator, and initial tests using the microphone seem to indicate that its the PC mic im using, not the one I plug inot the port replicator.

    serial port works great, USB woorks REALLY great, keyboard works great, why arent sound in and out working as suppsoed to?

    is tehre some sort of windows setting I can get at that will let me turn off the onboard speakers and onboard microphone?

  • #2
    Whiterabbit, been a few days before i could reply so i don't know if you have sorted it yet but I am using an IBM X21 with both docking station 2 and a port replicator (decided to just use the port replicator in the car so i can just use DC-DC and keeping the dock for my desk). I have exactly the same problem i.e. when i put speakers into the laptop it disables the speaker but when i put them into the dock (have not tried the port replicator) it doesnt. The only solutions i found were to press the laptop MUTE button near the screen which only mutes the laptop speaker out not the docking station one (so i guess the volume controls here dont affect this either - nor do they affect the windows volume setting)

    OR if you dont have this button you could just insert a jack plug into the laptop sockets with no wires on them - i think this will work cos whenever i put my 1/4" converter into my SB live drive it kills my sound as it thinks i have headphones connected.

    OR you could always open the laptop and use some wire cutters!

    Hope this helps.



    • #3
      Oh, forgot to say. I am using XP Pro without loading ANY IBM sound or thinkpad interface drivers. Can't remember if the volume controls affected the windows volume when i had the IBM Win2K install.


      • #4
        yes, this helps a bunch! I jsut got the stereo going for the first time in 8 weeks not one hour ago, so ill try the keyboard mute button and see if that does it, ill let you know!

        anyone have any ideas about the microphone?


        • #5
          no idea about the mic except again put a dummy jack plug (mono) in the mic socket on the side of your laptop and then use the mic socket on the port replicator for the real mic. (basically same botch as the speakers if the button doesnt work)



          • #6
            no, it doesnt figure it out in either case. side of the laptop, on teh port replicator. uses the laptop mic. its a real drag.


            • #7
              Hang on buddy, on my port replicator it doesnt have a mic input. it has line out and line in (circle with arrow in or out) and only has mic input on laptop. Will try out my mic tonight. DOes it actually take any input from the mic socket? you could always just block the existing mic with blue tac and tape - should muffle it pretty well - or desolder the connections if you are brave.


              • #8
                you are right, its line in. so thats the source of all my problems? im trying muting the mic and unmuting the line in.

                god bless easy to interpret symbols =/


                • #9
                  Right buddy did some testing on my X21 last night:

                  (oh and yeah you shouldnt really plug a mic into a line in - dunno if you can plug a self powered mic in or noth though and then you jsut have to mute the mic on the record settings and enable the line in)

                  I don't know how good you are with windows so i will be pretty basic - its not meant as an insult or anything just for completeness and you don't know who will be reading this afterwards:

                  Test I did:

                  1. used sound recorder to test the original mic - go to windows volume control click-[options]-[enable advanced]. Then [options]-[properties]-check the MIC option and then click recording and press ok. Now make sure that the box under mic volume is checked (on the recording screen now). i then pressed record on the sound recorder and mades some noise. I then stopped recording and pressed the advanced under the mic setting and enabled the boost and then did some more recording to see the difference the mic boost made - it was pretty impressive - but picked up lots of background noise.

                  2. I plugged in an old microphone into the side of the laptop and tried recording but nothing happened. So i tried clicking ont he advanced again and clicked ALTERNATE MIC but still nothing.

                  3. I then tried a creative mic - has a stereo style plug despite being only mono and tried it but nothing.

                  4. Disabled the alternate mic setting and tried it - worked but not sure which mic.

                  5. Turned off the mic boost and then did tests moving the mics as far apart as possible and speaking quietly into each one and trying unplugging the external one. Result: behaves exactly as it should - when the external mic is in turns off the internal one and when unplugged it reverts back to the internal one.

                  Basically: DO NOT USE ALTERNATE MIC SETTING
                  USE A MIC WITH A STEREO PLUG (i am pressuming my old mic does work with compatible equipment - i think the IBM is set up to accept stereo mics and doesnt like mono style connectors)
                  The mic boost is very effective
                  Use the recording setting to adjust the volume (or use the wizard in control panel when you are instalin in your car as it auto-adjusts)
                  leave the mic muted in normal playback so you dont get feedback - unless you want Car Karaoke of course!
                  If you want to use the line in i think you will have to use a powered i.e. self amplified mic or summit but i am really not sure about that. You could try the mic in the line in but make sure you enable the line in as the input in the recording properties screen (but you wont have a mic boost option).

                  Hope this gets you sorted.