Announcement

Collapse
No announcement yet.

Audigy 2 NX left channel only issue? help needed...

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Audigy 2 NX left channel only issue? help needed...

    OK, need some help with my audigy 2 NX external usb hub. I have double checked my connections and I can not figure out why I am only getting left channel audio. I have:

    4 Channel Amp running front and rear
    2 Channel Amp running subs

    I uses y splitters too hook up right into the back of the audigy NX. The front speakers (both of them) play front left channel audio and both back speakers play rear left channel audio. ???? I test this with the Creative speaker testing program. I am thinking that maybe the y splitters are the issue. I am 99% sure I bought "Stereo" y splitters. Would this be a problem if I bought "mono" y splitters? i guess I am just brainstorming the problem. Anyone have any ideas how to fix this? It has to be somthing I overlooked...
    My BMW 2004 330i

  • #2
    It definitely sounds like your cables are just standard mono Y-cable splitters -- which is not the cable you need. You need a cable that converts the headphone style connector into seperate L/R channels with RCA connectors. A stereo headphone connector will ALWAYS have 3 rings. A mono cable will USUALLY have only 2 -- though sometimes they have 3 also. To be certain, you can take a meter to the cable to check out how it is wired. Your description pretty much already confirms it though.
    2004 4runner

    Comment


    • #3
      FIXED!!! Thanks a ton. I over looked this
      My BMW 2004 330i

      Comment

      Working...
      X