Announcement

Collapse
No announcement yet.

Resume from hibernation, Volume level at 0

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Resume from hibernation, Volume level at 0

    Latitude C600
    Dell C/Port II Dock
    PCI soundcard (in Dock)

    When my laptop resumes out of hibernate, volume levels are at 0. Does anyone know why this might be happening?
    `
    ,,`,,
    ,,`,,
    ``,,`,,` `
    ,,`,,
    ,,`,,
    `
    `

  • #2
    I know this isn't the answer to your question, but frodo has made a command line program to set any volume to a specified percentage.. you can set the program to run upon resume-from-hibernation.

    I think you can get it at frodoplayer.com

    Just in case you never find a fix for this.

    Comment


    • #3
      That would work but having to turn the volume up/down everytime I get in my car would be a pain. I'm lazy!
      `
      ,,`,,
      ,,`,,
      ``,,`,,` `
      ,,`,,
      ,,`,,
      `
      `

      Comment


      • #4
        Originally posted by joshthepilot
        Did you really read what he said?
        Read!? No one actually reads this stuff josh. Don't worry though, someome will come and post a reply to this thread in 6 months like that other one ya *****ed about
        __
        Amoebacowboy

        "Do Not Taunt Happy-Fun Ball"

        Comment


        • #5
          Did you read what I said?
          `
          ,,`,,
          ,,`,,
          ``,,`,,` `
          ,,`,,
          ,,`,,
          `
          `

          Comment


          • #6
            Originally posted by blackflux
            Did you read what I said?
            There you go again not reading. If you check out the information about frodoplayer that wizawuza mentioned (and that josh pointed out you should read more carefully as it completely answered your question and solved your issue) there shall be light and rejoicing in the dark recesses of your mind.

            command line utility. sets volume to whatever the **** upon resume. happens automatically. no manual reset by you needed.

            Maybe we should use smaller words josh?

            And it's happening because it is. In other words, who the hell knows? Maybe it's mad.
            __
            Amoebacowboy

            "Do Not Taunt Happy-Fun Ball"

            Comment


            • #7
              Youre a funny dude!

              Riddle me this smart guy, if I set the volume to 60%. I get in my car and turn the volume up to 80% (I usually blast my music in the evenings). Oh wait, I have to stop at the gas station. I pump my gas, and then I get back in the car. Wouldnt I have to turn the volume back up?
              `
              ,,`,,
              ,,`,,
              ``,,`,,` `
              ,,`,,
              ,,`,,
              `
              `

              Comment


              • #8
                Originally posted by blackflux
                Youre a funny dude!

                Riddle me this smart guy, if I set the volume to 60%. I get in my car and turn the volume up to 80% (I usually blast my music in the evenings). Oh wait, I have to stop at the gas station. I pump my gas, and then I get back in the car. Wouldnt I have to turn the volume back up?
                I was dropped as a small child.

                Your original question was why does your soundcard reset to 0% after returning from hibernate. If you use the command line util mentioned you could set it at your usual default (60%) and adjust according to your listening preferences (it's night! Blast it!) afterwards. Or if you wanted to get really creative you could base the default sound level dependent upon the system's clock (after 5pm-set default volume to 80%, 7am-5pm sets to 60%) with a batch file tied to an "at" command (like cron jobs in unix). Until we get mind-controlled peripherals you'll have to manually adjust things at some point...
                __
                Amoebacowboy

                "Do Not Taunt Happy-Fun Ball"

                Comment


                • #9
                  Thanks, I really think it (volume level) has something to do with the fact that I am using a docking port and a PCI card with my laptop because I don't remember doing that before. I'll have to run some tests when I get home.
                  `
                  ,,`,,
                  ,,`,,
                  ``,,`,,` `
                  ,,`,,
                  ,,`,,
                  `
                  `

                  Comment


                  • #10
                    Now that i think about it, I don't know how difficult it would be to modify things to pull the current soundcard sound level setting prior to hibernation and modify the command line util to set that as the resume volume during the hibernate process. Hrm.. when I get home I'll take a look at seeing if that's doable.

                    Or we could, you know, try to figure out why your soundcard does what it's doing in the first place but where's the fun in that?

                    __
                    Amoebacowboy

                    "Do Not Taunt Happy-Fun Ball"

                    Comment


                    • #11
                      @joshthepilot, it's not muted, level is actually at zero.

                      @amoebacowboy, It would be easier to figure out why the soundcard is setting the volume level to zero... I am going to check out that comand line utility!
                      `
                      ,,`,,
                      ,,`,,
                      ``,,`,,` `
                      ,,`,,
                      ,,`,,
                      `
                      `

                      Comment


                      • #12
                        Originally posted by blackflux
                        @joshthepilot, it's not muted, level is actually at zero.

                        @amoebacowboy, It would be easier to figure out why the soundcard is setting the volume level to zero... I am going to check out that comand line utility!
                        Try putting the soundcard into the laptop PCcard slot and not the docking station and see if it goes away. Sounds like your on the right path with suspecting the docking station hookup being the issue.
                        __
                        Amoebacowboy

                        "Do Not Taunt Happy-Fun Ball"

                        Comment


                        • #13
                          It's a PCI card....
                          `
                          ,,`,,
                          ,,`,,
                          ``,,`,,` `
                          ,,`,,
                          ,,`,,
                          `
                          `

                          Comment


                          • #14
                            Originally posted by blackflux
                            It's a PCI card....
                            Bah. Luxury! Push it into the slot really really hard. I would also suggest lubricating the card with something to make it slide in a little easier. Maybe Crisco or olive oil. Sacrificial black chicken is optional.
                            __
                            Amoebacowboy

                            "Do Not Taunt Happy-Fun Ball"

                            Comment

                            Working...
                            X