Announcement

Collapse
No announcement yet.

USB repeater as "unknown device"

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • USB repeater as "unknown device"

    Ahhh...i have everything working in my rough car setup right now except for 2 problems. Noise and the touchscreen.
    For now i am just trying to get the touchscreen working.

    The USB repeater this exact one that i have coming from the trunk to the front which connects to the Xenarc is showing up as "unknown device" in Windows XP (with service pack 2).

    its a usb 2.0 repeater (15ft long) going into a usb 2.0 port of a SOYO SY-k7vme motherboard. I have tried everything I can think of for this fix but still its showing up as an "unkown device" and when i plug the xenarc usb into it, it does nothing.

    Any one else encounter this problem?

    I am thinking its the cable, i would pull it out and test it on my house pc but its already going underneath the car carpet and i sure would hate to pull it out and find out it works fine.

    P.S. on the properties for the unknow device it says "no drivers installed or needed" something like that. I was under the impression that WinXP SP2 provided the drivers.

    ANY IDEAS? all i have left to try are pulling the cable out and testing it (alot of work involved) or adding a PCI USB and plugging the repeater on it and see if resolves the issue.

  • #2
    Have you tried it on another machine?? My Bluetooth now does this, it was working - nothing changed, I think it died :-(

    Comment


    • #3
      Why are you using a USB repeater? Is your carputer mounted in an RV or something? I've used 20' USB cables without any problems, and especially if you're using it for something like a touchscreen...

      A repeater just sounds like an added point of failure that is not needed.
      Chrysler 300 - Fabricating
      http://hallert.net/

      Comment


      • #4
        Why are you using a USB repeater? Is your carputer mounted in an RV or something
        How else can i extend the usb cable coming out of the xenarc all the way to the trunk??? If there is another way please enlighten me. The repeater is pretty much a usb hub.

        My future plan was to put a USB hub to that repeater and put the xenarc usb into it in the future but i cant even get past this part.

        Comment


        • #5
          How are you powering the repeater?

          Comment


          • #6
            Uh, why not just use a USB extension cable? Totally inert, no electronics, it just extends your USB device up to 15-20 feet away. That's what I was just talking about.
            Chrysler 300 - Fabricating
            http://hallert.net/

            Comment


            • #7
              Originally posted by Scouse Monkey
              How are you powering the repeater?
              Its self powered...when i plug it in the usb port it detects it but then when WinXP searches for drivers it says "cant not find driver" and as far as i know this is suppose to be a plug and play.

              My plan was to run that usb repeater (aka usb extension) from the trunk to the armrest and then plug in a powered mini-usb hub on that and then plug whatever i needed into the powerd mini-hub like xenarc and etc. I already have the +5V line and ground running from the opus molex to the arm rest so ALL my major wiring is done.

              Since i only have need for ONE USB port for right now I was plugging the xenarc USB into the extension directly and not using the hub. I dont think adding that hub will make a difference.

              why not just use a USB extension cable?
              Well that is what this essentially is, i think extension and repeater are just 2 different words for the same thing. Also, the usb extension/repeater is type A (male-going to pc) to type A (female-accepting the male input from xenarc). Before I bought the xenarc i thought it used a type B connection so i bought a 15' usb type A to type B and thats why i cant use that kind of an extension, if thats what you meant.

              Comment


              • #8
                An extension doesn't have a driver - only the other peripherals on the end.

                Comment


                • #9
                  yeah thats what i thougth, but when i connect it, it detects it as a hub first then after trying to get a driver for it, it calls it an unknown device. I have put the link for the extension above, is this the wrong thing i am using????

                  if it is, what should i be using?

                  P.S. i am working on my car, so ill be checking every few minutes....thanks for any suggestions!

                  Comment


                  • #10
                    Hmmm .... reading the comments on the website sounds like someone else has it working perfectly ... do you have the correct chipset drivers loaded in XP??

                    Have you tried it on a different machine?

                    Comment


                    • #11
                      yes i just loaded the latest chipset driver yesterday night from SOYO motherboard website.

                      And no i have not tried it on another machine because i didnt think about testing it before i ran the cable in the car...it will be a pain to pull it out, I am going to put a pc in the garage and try that as soon as i can. I am hoping its some setting that i have overlooked b/c i really dont want to replace the extention cable or the motherboard. I'll go crazy if i have to reinstall windows again.

                      Comment


                      • #12
                        i have gave up and decided that its probably the active usb repeater thats messed up and i am going to pull it out tomorrow and send it back for rma. I'll be sure to test it before i run it underneath the carpet next time.

                        In the mean time i have ordered regular usb extensions and will see if that will work for the time being.

                        Comment


                        • #13
                          My understanding of an active USB cable is that it is essentially a 1-port hub. Therefore, if you are placing a hub at the end of a 15' USB cable it is the same exact thing. For the distance you are running your cables an active one is not necessary.

                          As far as your problem... I have no idea how to fix that. I seriously doubt any drivers are needed but I can't say for sure cause I've never owned an active USB cable.
                          http://www.cardomain.com/id/seanklsc

                          Comment

                          Working...
                          X