Announcement

Collapse
No announcement yet.

OH NO! My EPIA-M BIOS is corrupt! any help pls?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • OH NO! My EPIA-M BIOS is corrupt! any help pls?

    I tried upgrading my VIA EPIA-M (10000) BIOS to a newer version. Ive done BIOS's hundreds of times and before I did the upgrade I saved my old bios on the RAM drive my boot CD created. During BIOS upgrade it gave me "write fail" errors so I tried reinstallting the all BIOS and but then that wouldnt work due to checksum error. So crossing my fingers I rebooted machine and now the mobo gives me a couple of beeps then a low pitch beep and nothing more. Its dead

    As a desperate attempt I tried using the reset BIOS jumper, but that didnt work.

    Has anyone had the problem before? how did you fix it if you did? I rang my mobo supplier and they dont sell BIOS on their own and VIA themselves moved their office overseas (I am in Sydney, Australia). My only alternative at this point is new mobo.

    The BIOS chip has the following stuff printed on it:

    SST
    39SF020A
    70-4C-NH
    0345167-D

    Any help would be appreciated. Thanks

    Car PC v1 - 1999 - 2000
    DOS 6.22 - MPXF - 2x16 LCD - 6.4GB
    Car PC v2 - 2002 - 2006
    XP - 7" wide/touch - GPS - Tank batt relay - 100GB
    Car PC v3 - 2008
    XP - 7" wide/touch - GPS - 802.11g - FM/XM - OBDII - WWW

    [||||||||||||||----] 80% complete

  • #2
    The reset bios jumper is to set it back to default settings and wouldnt help u in your situation you would have to send it to VIA i think not too sure.
    CarPC Status:
    GPS: 99%
    Hardware: 99%
    Software: 92%
    Case Install: 99.9%
    Dash Install: 100%
    Car Install: 72%

    Comment


    • #3
      Ther are companies that will reflash your bios chip if you send it to them. Have a Google. There's also another method if you can get a willing friend with the same motherboard where you boot the good mobo, extract the BIOS chip with the PC running, repalce with the bad chip and reflash.
      Car news and wallpaper site: www.carfeed.net

      Comment


      • #4
        This might work.



        http://forums.windrivers.com/showthread.php?t=63443

        Comment


        • #5
          i had this problem n just got a new preloaded bios chip from ebay. It was less than 20 bucks and took 3 days to get here. Ebay search bios flash
          mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
          Follow Me on Twitter or Facebook
          Live mp3Car Facebook Chat

          Comment


          • #6
            thanks for the help guys.
            I followed the instructions found here: http://bev.gotdns.com/ruslan/Updated...overy_tips.htm

            After a fair few hours of trying I could not get the carpc BIOS to work. I tried 3 different BIOS chips (all the same 256kb as the original) but still no go. I tried aflash bios, uniflash, awd and none of them flashed it well enough for it to work. On the up side though, the idea itself is great and it works in other cases. I accidentally wiped out my desktops BIOS while testing out the BIOS chips (flashed desktop BIOS instead of spare one) but luckily I was able to recover it on my 2nd desktop using the techniques in the link above. So I have NO idea why it wont work for the carpc bios. ahhh well

            I tried... im still open for suggestions

            Car PC v1 - 1999 - 2000
            DOS 6.22 - MPXF - 2x16 LCD - 6.4GB
            Car PC v2 - 2002 - 2006
            XP - 7" wide/touch - GPS - Tank batt relay - 100GB
            Car PC v3 - 2008
            XP - 7" wide/touch - GPS - 802.11g - FM/XM - OBDII - WWW

            [||||||||||||||----] 80% complete

            Comment


            • #7
              http://cgi.ebay.com/new-Replacement-...QQcmdZViewItem

              Comment


              • #8
                http://www.recoverybios.com/
                Although it wasn't enough to save my EM586 unfortunately.
                Old Systems retired due to new car
                New system at design/prototype stage on BeagleBoard.

                Comment


                • #9
                  Just a follow-up on this thread. I was able to [finally] fix the problem.
                  After MUCH MUCH MUCH frustration I found that the BIOS chips arent a standard, as I thought it was. There are different ways to write to the chips (LLC and PP i think) aswell as them running on different voltages (3v, 5v and i think 3.7v). To top it off they come in diff sizes, although the most common is 256k and its hard to find a diff size really.
                  So basically I had to replace my BIOS with the same chip or something with the same specs and not only that, the mobo had to be similar too!!! (correct voltage and way it writes to chip). To add to the mix the program you used to flash needs to have an option to force a BIOS onto the incorrect chip (using a diff mobo with a diff bios chip in it for my carpc).

                  The solution was this. I borrowed my friends VIA EPIA (800Mhz model, as opposed to my M10000, it had a sliiightly diff model BIOS chip but luckily it still worked). Using Awards flash utility I tried flashing it but it wouldnt let me (wrong BIOS version for mobo). I used the switch /QI to force the flash. The final command was something like this: awfl823b i0100116.bin /py/QI

                  So yeh, all good now thanks for the help guys.

                  oh btw, I found a GREAT site for BIOS stuff.
                  http://www.wimsbios.com/

                  There forums are here:
                  http://www.wimsbios.com/phpBB2/index...98923f0152524a

                  Hopefully this thread will save A LOT of hassles for someone else

                  Car PC v1 - 1999 - 2000
                  DOS 6.22 - MPXF - 2x16 LCD - 6.4GB
                  Car PC v2 - 2002 - 2006
                  XP - 7" wide/touch - GPS - Tank batt relay - 100GB
                  Car PC v3 - 2008
                  XP - 7" wide/touch - GPS - 802.11g - FM/XM - OBDII - WWW

                  [||||||||||||||----] 80% complete

                  Comment

                  Working...
                  X