Announcement

Collapse
No announcement yet.

Rand McNally GPS drives my PC WILD...

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Rand McNally GPS drives my PC WILD...

    I have the Rand McNally GPS receiver, and about 50% of the time when I boot my car PC up, I think it mistakes the receiver for being a mouse, since it is plugged into the ps/2 port and the serial port. It sends the pointer flying wildly all over the screen, as soon as I pull it out of the ps/2 port (which apparently it uses for power), it ceases, but of course then I don't have GPS ability. Anyone run across this? I use a 10.4" Datalux touchscreen with my setup, which plugs into the other serial port.

  • #2
    Hey that sounds bad, luckily for myself I just bought the Rand McNally GPS also - but the USB version that is new.

    Have you tried plugging it into your keyboard ps2 port for power instead?

    Also have you flashed your computer bios to the newest one?
    SP13000|M2-ATX|512MB DDR400|2.5" 7200RPM S-ATA|Trans-7"|Slim SL DVD-CDRW|KEH 5.1 DSP|SB L!ve Ext|Gyration PowerMate|BT|WiFi|GPS|WinXP|VoomPC
    GPSing - Digital Speedo
    Relocating headunit and extending faceplate
    Button app to Alt-Tab between two programs

    Comment


    • #3
      one a semi related note, where can i buy the mcnally receiver for cheap?

      Comment


      • #4
        Hey!

        thats what happens to my gps reciever... Lol... check oiut my thread about it: http://www.mp3car.com/vbulletin/show...&threadid=7053

        what i did is I let my computer boot up and let my mouse jump all over the screen for a few secs.... Then, I disconnected the power source (in my case AA batteries) and the jumping stopped. So then I went to device manager and disabled the serial mouse that was conencted.... put the batteries back in and reboot... the device stayed disabled and CoPilot picked up my gps no problem..
        -Jason..
        Car
        1964 Ford Falcon powered by a 1993 Mustang 5.0 EFI, AOD transmission, with disc brakes up front and more mechanical goodies
        The Player
        Gone! Soon goign to repalce the screen based system i HAD with an iPod. http://mp3falcon.crazyshaxs.com

        Comment


        • #5
          ok one VERY useful info for those using the randmcnally. You can just cut the power plug (PS/2) find out which is the +5V and the ground...... and hook that up to the 12V from the car. Doesn't have to be regulated either. The specs of the randmcnally is something like 4V to 15V. So any voltage at that range will work fine.
          Dont mess with the PS/2 port, specially if you have "mouse" problems hehe
          04 Acura TL w/ core2duo 2ghz laptop w/ 1gb RAM on a docking station.

          Fast car, fast PC. ;)

          http://www.arcdesigns.net/carpc/

          My TL CarPC ver2

          FSR Flash Skin w/ moving weather maps

          Comment


          • #6
            Great insight moahdib!

            thanks
            Pigseye

            Comment


            • #7
              Glad I bought the new USB one. Less cables.
              www.randmcnally.com
              Paid $150 though shipped. But I want it bad! Use it on my laptop until my carputers done. USB hopefully is ez.
              SP13000|M2-ATX|512MB DDR400|2.5" 7200RPM S-ATA|Trans-7"|Slim SL DVD-CDRW|KEH 5.1 DSP|SB L!ve Ext|Gyration PowerMate|BT|WiFi|GPS|WinXP|VoomPC
              GPSing - Digital Speedo
              Relocating headunit and extending faceplate
              Button app to Alt-Tab between two programs

              Comment


              • #8
                Hmm...when the pointer is freaking out and I go into device manager, I don't have a serial mouse that was detected. So far the only solution seems to be to reboot and hope by the luck of the draw that when it boots up it won't have the problem. Is there anyway to prevent the serial mouse driver from being loaded??? Or even a way to prevent any type of mouse being loaded? I use the Datalux 10.4 touchscreen and it has its own drivers for the serial port touching interface.

                Comment


                • #9
                  I think this one has pretty much been mentioned before, but have you tried to use the keyboard input for power.

                  I have another brand where power is ps2 and communication is a serial port connector.

                  if your gps use the ps2 for both power and comms, you might be able to use a converter from ps2 to serial. I'm not sure how much power the serial port can deliver ...



                  Another option is if your datalux touchscreen is a serial port, try switching them around, this might catch your problem ...



                  If nothing of this works, you might want to contact Rand McNally and have them figure out what is wrong.

                  Comment


                  • #10
                    The GPS uses the PS/2 for power and the serial port for communication. It does not matter if it is plugged into the ps/2 mouse port or the keyboard port, it still gets power either way and sends my pointer flying all over the screen. I'm not sure why switching the serial ports would make a difference. I would tend to think the PC would pick up COM1 first and then COM2 secondly when it boots windows. My touchscreen is plugged into COM1 and the GPS is plugged into COM2. I think I'll be giving rand mcnally a call.

                    Comment


                    • #11
                      Rand Mcnally

                      i found a little tidbit to possibly fix this Problem..

                      enter Regedit

                      [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\sermouse

                      New DWORD Value

                      Value Name " Start "
                      Value data " 4 "
                      Base Hexadecimal

                      I hope it works for all of you as it did me.

                      I dont use a Touch Screen, so i dont know if it will cause a problem with that.

                      Have Fun..

                      Comment


                      • #12
                        Wow, a solution to the problem arrives 1 yr later

                        What OS did you try this on?

                        Comment


                        • #13
                          if my previos fix dosent work, On 2000 try this one...

                          http://support.microsoft.com/default...b;en-us;283063

                          If microsoft pulls a Microsft and pulls the link, here are the Details.

                          Start Registry Editor (Regedt32.exe). To do this, click Start, click Run, type regedt32 in the Open box, and then press ENTER.
                          For instructions on how to identify the Enumerator, DeviceID, and InstanceID for your COM Port refer to the URL Abive..
                          HKEY_LOCAL_MACHINE\System\CurrentControlSet\Enum\E numerator\DeviceID\InstanceID\Device Parameters

                          Note that there is one InstanceID for each port.
                          On the Edit menu, click Add Value, and then add the following registry value:
                          Value Name: SkipEnumerations
                          Data Type: REG_DWORD
                          Radix: Hexidecimal
                          Value: 0 through FFFFFFFE

                          Note that a value of zero (0) disables the feature and device detection can resume. Each time that Plug and Play does an enumeration, it counts down one, and when it counts down to zero, it re-enumerates the hardware and then starts counting down again from the registry value. When you reboot the computer, Plug and Play starts the count again at the value that you typed.
                          Quit Registry Editor.

                          Comment


                          • #14
                            This is really quite random, but looking for something completely unrelated (switch options in the boot.ini file), I found something that could be quite useful in reguards to this thread. If you add the following switch to your boot.ini (c:\boot.ini) for Win2k, and I'd assume WinXP, it will disable serial mice.

                            /NOSERIALMICE=[COMx | COMx,y,z...] Disables serial mouse detection of the specified COM port(s). Use this switch if you have a component other than a mouse attached to a serial port during the startup sequence. If you use /NOSERIALMICE without specifying a COM port, serial mouse detection is disabled on all COM ports. See Microsoft KB Article Q131976 for more information.
                            -Nick

                            _____________________________
                            Since when is insanity a bad thing?
                            www.mp3vw.com

                            Comment


                            • #15
                              SUperMATTY

                              Super, Much disappointment

                              it's picking it up as a Serial mouse, go and disable it, and continue working like it didn't even happen....
                              What I did, I turned the computer on...the mouse was going crazy....I unhooked the GPS, while the comp was still on...went to device manager, and then disabled it....
                              haven't had a prob since....let us know how it works for you!
                              If you do a SEARCH you will notice that a lot of people have had the same problem, and found that this solution works!

                              and here is the
                              link


                              Oh by the way...I just saw the DATE...I'm sorry....
                              BossTone74

                              Comment

                              Working...
                              X