No announcement yet.

Need help with new CarPC and USB GPS

  • Filter
  • Time
  • Show
Clear All
new posts

  • Need help with new CarPC and USB GPS

    I searched and found a few posts somewhat related to my issue but nothing specific and nothing with a solution. I'm hoping some here may have an answer that could help me.

    I'm putting together my 1st CarPC. When I set it up inside it works fine but when I use it in my truck the USB GPS mouse is not found.

    I tracked it down to the difference between using power from my house and using power from my 400 watt inverter.

    I tried using a powered USB hub and it didn't help. I changed to a 750 Watt inverter and it didn't help either.

    Other than this the PC runs fine. I'm not sure how accurate it is but the meter on my inverter says it's pulling about 40 watts.

    I know the GPS mouse works b/c I've used it on my laptop and another smaller desktop for testing.

    This is the GPS mouse I'm using:

    This is the PC I'm using:

    Sorry for the long post. I'm hoping someone will have a solution do I don't have to scrap this PC for this project.

    Thanks for any help.


  • #2
    Is the GPS connected to a USB hub or directly to the PC?
    If it's in a hub, try conencting it directly to a USB port on the motherboard.
    Have you looked in the FAQ yet?
    How about the Wiki?

    Under normal circumstances, a signature would go here.


    • #3
      Originally it was directly to the PC. Tried it with the two USB in the back and the two usb in the front.

      When I realized it was related to how I had the PC powered I tried a powered USB hub and it still didn't work.

      So yes in the PC directly and yes in a powered hub.


      • #4
        If your PC runs well, the GPS must works.. it is powered from the 5v rail, and a GPS suks 80mA (very low power). Forget the usb hub, it would cause troubles, you said you tried it directly to the PC: but it works there... or don't?


        • #5
          I don't think I was clear in my original post.

          It works either way (with or without hub) if I use AC power from the house.

          It does not work either way (with or without hub) if I use power from a 400 watt or 750 watt inverter.

          This is the problem.

          I suspect there may be a problem with the 5V rail.

          If I can't get this worked out I think I'll persue a serial GPS mouse.

          Thanks for the replies.


          • #6
            might be a bit unstable inverter?

            is the inverter a square pulse inverter or a sinusinverter? some powersupplies have a strange "pulsating" on the 12v and 5 v if its square pulse, some electronics pick up the pulsating and dont boot, had a wireless network usb-adapter that worked indoor and not in the car, used a voltage regulator chip on the wire and it vorked fine after that

            p.s. sorry about the poor english,


            • #7
              Turns out it was a noise problem in the +12V. I grounded the inverter to the PC and the PC to the truck chassis and it started working. I also got rid of all the noise in the audio.

              Thanks for the help. This site is excellent.