Announcement

Collapse
No announcement yet.

Temperature reading in Fahrenheit..How?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Temperature reading in Fahrenheit..How?

    Ok, I finally got the FB hooked up yesterday and have been tinkering with it. I have been able to run the wizard and complete a skin very easily to display the 2 temperature probes I have, as well as see the lights on the board when toggling the Digital Outputs on and off. (Waiting for the relays and photo cell I ordered yesterday from the Fusion Store )

    What I can not seem to figure out is how to convert the celcius reading to Fahrenheit. I tried adding a function on the configurator, and it shows the nice little flow chart, but I can't figure out how to "pin it" to a certain input. (I have the temp sensors on ports 0 and 1)

    I also opened the Celcius to Fahrenheit.xml trying to get a clue how to possibly do it in there with no luck.

    I did a search in the FB forums here, for "Fahrenheit" and read all posts containg it, but none tell how to display the temp in Fahrenheit.

    Any help is greatly appreciated!
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  • #2
    Just to get used to it do the following...

    Use the ninja kitty wizard and make 1 analog input as a Tempature Sensor.

    Then when it's all said and done, go to the top and click "Behind the Scenes Logic" the Icon with the gears. In the lower right graphical window you will see tabs with your Analog input(s). Click the correlating tab and then click the "Paper and Pencil" icon for Edit Logic Statement.

    This is where I got lost for hours and would not have known what to do had I not found a post on here.

    Over to the left click the "Add an already programmed function, and click Celcius to Fahrenheit. You'll see the Icon on the layout now, I believe this where you have gotten to. Put it between the the temp sensor logic icon and the output Green arrow icon, then link the nodes. To link the nodes. "Right Click a node, then left click the node you wish to connect it to. It should work. Once your nodes are connected that's it..Save it and continue. They should work.

    Comment


    • #3
      Exactly.

      Nice to see people helping each other out... opens Nick and I up to new development

      Comment


      • #4
        Hah, least I can do, it only took me forever to figure that out..LEAST I can do when the guy develops the best RR skin period for me to use!

        Comment


        • #5
          While we are on the topic, how do I get rid of the decimal and precision data for the temps? Instead of 72.16 degrees Just Tenth place numerical values like "72". It fluctuates too much in the precise decimal manor.

          Comment


          • #6
            Thanks for the info! I got to the point of adding the C to F conversion onto the chart. When I "Right click a node" all I get is a context menu (See screen cap below). If I ignore that, and click the node I want to connect to, it duplicates the one I am clicking on.

            Note: the function in the top right, left above and left of the green arrow is the F to C conversion function.

            On another note, the letters are so run together it is impossible to read what is what.... maybe a bug?
            Attached Files
            Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

            My Fiero Build Thread

            Comment


            • #7
              Originally posted by Dougw133 View Post
              While we are on the topic, how do I get rid of the decimal and precision data for the temps? Instead of 72.16 degrees Just Tenth place numerical values like "72". It fluctuates too much in the precise decimal manor.
              Looks like there are several different ways to accomplish this but here's the way I do it. I assume you already have the skin built so just open it up and double click text labels in the top left window. Then find the one you want to change and double click it. You should get a pretty big dialog box which has decimal precision at the bottom. I think the default is 2 so either delete it for just whole numbers or make it 1 for one decimal place. Click the check, save the skin and you're done.

              Comment


              • #8
                Ummm, you can click and hold to drag those icons wherever you want so you can read the text. I think the node they are talking about is the little ring. Looks like you right clicked the icon. So select the node you are coming from and right click the little ring and then left click the little ring that you are going to.

                The inputs (little rings) are on the left side of the icon and that icons outputs (little rings) are on the right side. So you are going from an output to the next icons input.

                I think I described that right.

                Comment


                • #9
                  Originally posted by jss812 View Post
                  Looks like there are several different ways to accomplish this but here's the way I do it. I assume you already have the skin built so just open it up and double click text labels in the top left window. Then find the one you want to change and double click it. You should get a pretty big dialog box which has decimal precision at the bottom. I think the default is 2 so either delete it for just whole numbers or make it 1 for one decimal place. Click the check, save the skin and you're done.
                  Are there like many different versions of this software or something? I have the latest version, as when I installed it from the installer, after it was done, got all the balloons in the system tray saying it was updating..... and eventually "all files updated."

                  When I follow the above steps, I "find the one I want to change", double click on it and the dialog box has nothing about decimal places, the last entry at the bottom of the dialog is "history to keep".
                  Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

                  My Fiero Build Thread

                  Comment


                  • #10
                    You can click and drag any of those
                    Icons" and the the nodes will stay connected unless you manually break them. So I move the icons. To move a fucniton/icon left click on it and it will be come draggable. Don't click and hold like you would in windows. Move them apart so you can work with htem. I made a mistake above. Here is what it should look like.

                    Click image for larger version

Name:	FBconfig.jpg
Views:	1
Size:	35.5 KB
ID:	2272919

                    You have to click on the NODE, the little black line leading to the circle on the end of a fucniton icon. If you miss you'll get that info box about the fucntion. Nothing will hapen when you click the node until you attatch it to another. It won't do anything graphicaly until the connection is complete.

                    So its, LEFT click on the node and RIGHT click to attatch to the next node of choice.

                    Comment


                    • #11
                      Woa lots happened while I was making that post!

                      Comment


                      • #12
                        Originally posted by jss812 View Post
                        Ummm, you can click and hold to drag those icons wherever you want so you can read the text. I think the node they are talking about is the little ring. Looks like you right clicked the icon.

                        Thats it exactly! I was clicking on the icon, thinking that was selecting what I wanted to link from / to. Right clicking on the "little rings" did the trick! Thanks!
                        Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

                        My Fiero Build Thread

                        Comment


                        • #13
                          Originally posted by Dougw133 View Post
                          You can click and drag any of those
                          Icons" and the the nodes will stay connected unless you manually break them. So I move the icons. To move a fucniton/icon left click on it and it will be come draggable. Don't click and hold like you would in windows. Move them apart so you can work with htem. I made a mistake above. Here is what it should look like.

                          [ATTACH]52738[/ATTACH]

                          You have to click on the NODE, the little black line leading to the circle on the end of a fucniton icon. If you miss you'll get that info box about the fucntion. Nothing will hapen when you click the node until you attatch it to another. It won't do anything graphicaly until the connection is complete.

                          So its, LEFT click on the node and RIGHT click to attatch to the next node of choice.
                          Oh my, I stand corrected. I was mistaken about the click and hold. Just click is what works.

                          As far as linking goes, I work from left to right so I have to right click an output from one node and then left click to the input node of the one I'm going to. Hmmm, if that makes sense.

                          Comment


                          • #14
                            Originally posted by JohnWPB View Post
                            Are there like many different versions of this software or something? I have the latest version, as when I installed it from the installer, after it was done, got all the balloons in the system tray saying it was updating..... and eventually "all files updated."

                            When I follow the above steps, I "find the one I want to change", double click on it and the dialog box has nothing about decimal places, the last entry at the bottom of the dialog is "history to keep".
                            I've only used the version they have on their website so I don't know about different versions. Are you sure you went to the top left window and double clicked "Text Labels"? (the icon in there has two "A"s, one larger than the other, in it). So, as soon as you open you're skin in Configurator, you should be able to go there.

                            Comment


                            • #15
                              Man, this should not be this difficult hahah! I have created the new function as mentioned above, however it will NOT let me link it. I have tried just about everything, and keep getting the error. I am right clicking the Temp Sensor [Celcius] node (on the right side) and the Celcius to Fahrenheit function (on the left side) and get the error shown.

                              Do you have to break the original connection somehow first? Any last suggestions?
                              Attached Files
                              Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

                              My Fiero Build Thread

                              Comment

                              Working...
                              X