Announcement

Collapse
No announcement yet.

100% CPU usage running MDX

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 100% CPU usage running MDX

    Somewhere along the line something has happened on my computer that is causing issues with Fusion Control Centre. Basically, whenever MDX is in the foreground, the CPU usage sits at 100%. This happens no matter which skin I use - even the default one and if no brain is attached. If the program is minimised, it drops down to the (expected) single figures.

    I have tried
    • reinstalling the latest MDX software and updates and rebooting;
    • installing the latest directx redistributable (from March 2009);
    • running in "basicgui" mode;
    • playing around with the "gui" timer to make it refresh much slower
    and still have this CPU usage problem. Any suggestions as to what might be causing this issue?

    P.S. This may be unrelated but watching the memory usage it appears to be going in a pattern repeating every few seconds - e.g. 39,000 kB, 56,000kB, 70,000kB and then returning to 39,000kB, etc. (these numbers are not exact but merely representative).

  • #2
    What CPU are you running?

    Comment


    • #3
      I am running a VIA C7 2.0 GHz with 1Gb RAM under Windows XP. Never had a problem running FCC MDX until recently. No other applications are running while FCC is maxing out my CPU. No other process is using more than the occasional 1 or 2% CPU.

      I have just tried removing FCC MDX and all of the .NET frameworks installed on my computer then reinstalling FCC MDX and it still has the CPU usage issue. I'm puzzled as what to do next....

      Comment


      • #4
        Wait for Nick (2k1toaster) to get out of the hospital.

        Comment


        • #5
          What are the timers set to?

          GadgetBandit?

          Comment


          • #6
            Ok... I think I found the problem. Somewhere along the line (probably due to a Windows update) the Direct3D Acceleration option under the Display tab of the dxdiag.exe utility had been disabled. I simply enabled it again and the CPU usage has now dropped dramatically when the MDX window has focus

            This testing is just with the default skin; I have yet to try it with my custom skin, but don't see why it wouldn't work now.

            Comment


            • #7
              Good to know it is working. Also just FYI the Virtual Brain is pretty cpu intensive as well so I dont know if that would work on a Via chipset.
              Fusion Brain Version 6 Released!
              1.9in x 2.9in -- 47mm x 73mm
              30 Digital Outputs -- Directly drive a relay
              15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
              Buy now in the MP3Car.com Store

              Comment

              Working...
              X