Announcement

Collapse
No announcement yet.

COM Rider Runner problem with MDX

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • COM Rider Runner problem with MDX

    Having problems changing pages with buttons in Ride Runner. Sometimes they work, sometimes nothing and other cases I get screens blinking back and forth between views. I started with one variable, then tried a different variable for each case.

    Code:
            <command id="dayview" minimum_delta_vote_time="100">
              <do function="Change Variable" functionTargetID="View_day" vote_opinion="1" vote_priority="Medium"></do>
            </command>
            <command id="nightview" minimum_delta_vote_time="100">
              <do function="Change Variable" functionTargetID="view_night" vote_opinion="1" vote_priority="Medium"></do>
            </command>
            <command id="ledview" minimum_delta_vote_time="100">
              <do function="Change Variable" functionTargetID="view_led" vote_opinion="1" vote_priority="Medium"></do>
            </command>
          </commands>
          <executable_commands>
            <external_COM_id id="RoadRunner.SDK">
              <command internal_id="roadrunnercommand_nightskin" external_command="Execute">
                <parameter order="0" external_command_parameter="nightskin"/>
              </command>
              <command internal_id="roadrunnercommand_dayskin" external_command="Execute">
                <parameter order="0" external_command_parameter="dayskin"/>
              </command>
            </external_COM_id>
          </executable_commands>
    Code:
          <if fire_on="logic" minimum_delta_vote_time="100" id="Dayskin_manual">
            <boolean_operation type="equal to">
              <parameter1>
                <variable do="get" name="view_day"></variable>
              </parameter1>
              <parameter2>
                <number>1</number>
              </parameter2>
            </boolean_operation>
            <then>
              <do function="Change Page" functionTargetID="Required Filler" vote_opinion="0" vote_priority="Medium"></do>
              <do function="Change Variable" functionTargetID="view_day" vote_opinion="2" vote_priority="Medium"></do>
            </then>
          </if>
          <if fire_on="logic" minimum_delta_vote_time="100" id="Nightskin_Manual">
            <boolean_operation type="equal to">
              <parameter1>
                <variable do="get" name="view_night"></variable>
              </parameter1>
              <parameter2>
                <number>1</number>
              </parameter2>
            </boolean_operation>
            <then>
              <do function="Change Page" functionTargetID="Required Filler" vote_opinion="2" vote_priority="Medium"></do>
              <do function="Change Variable" functionTargetID="view_night" vote_opinion="2" vote_priority="Medium"></do>
            </then>
          </if>
          <if fire_on="logic" minimum_delta_vote_time="100" id="LED_Manual">
            <boolean_operation type="equal to">
              <parameter1>
                <variable do="get" name="view_led"></variable>
              </parameter1>
              <parameter2>
                <number>1</number>
              </parameter2>
            </boolean_operation>
            <then>
              <do function="Change Page" functionTargetID="Required Filler" vote_opinion="1" vote_priority="Medium"></do>
              <do function="Change Variable" functionTargetID="view_led" vote_opinion="2" vote_priority="High"></do>
            </then>
          </if>
    My external commands to switch RR skins just disappear from the "then" statements when I run the software. I've been poking at this for days now. It worked last night, but when I tried it again this morning nothing would change.

  • #2
    Some more data. When I hit the button in RR, I see the variable change to 1.5 instead of the designated 1. I changed the variable to 1.00, but that didn't make a difference. MDX continues to flicker through the screens after shutting down RR. I seem to get one clean screen switch. The next selection either doesn't switch or goes into flicker mode.

    Comment

    Working...
    X