Announcement

Collapse
No announcement yet.

Serial Port issues, Please HELP.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Serial Port issues, Please HELP.

    I have started to have serial port issues. When I first start the PC, everything works, XM, HD Radio, OBD2 and AMP_CTRL. If I open anything that is serial, it will freeze after a certain amount of time. At first I thought it was CF, but then I tried Mitch's HD Radio application and after 2 minutes I tried to change the channel and his app frooze. My setup worked perfect, the only thing I can think that could be the issue is that I started to use AMP_CTRL, before I used Volume_Amp_Ctrl, could that be the issue? I also started to use a device called a PAC TR-4, its a remote trigger for all of my AMPS. http://www.buy.com/prod/pac-tr-4-low.../90129363.html. Only other thing I can think of is that the PAC TR-4 is not connected correctly. I have the green wire connected to pin 4, then it has a ground. Should I connect this ground to the ground on the serial port? currently I have it connected to my distrobution block. What else should I try to do to trouble shoot?
    Nirwana Project, the Android/Win 7 hybrid system!

    1X Ainol Novo Flame Tab
    4X MK808b
    3x Perixx Touchpads
    3x 7 inch Screens
    1X 7 inch motorized Screen
    1x Win 7 PC

  • #2
    What kind of serial ports? Are they built in serial ports from the motherboard, or are they some sort of USB-serial adapter?

    For troubleshooting, disconnect all other serial "stuff" so you can determine where the problem is. ie. Work with one serial device only, unplug the rest. This will eventually tell you where the problem lies.

    Comment


    • #3
      Originally posted by BlackStealth View Post
      What kind of serial ports? Are they built in serial ports from the motherboard, or are they some sort of USB-serial adapter?

      For troubleshooting, disconnect all other serial "stuff" so you can determine where the problem is. ie. Work with one serial device only, unplug the rest. This will eventually tell you where the problem lies.
      These are serial ports on the MoBo. I have a feeling something is wrong with them and rather then waste anymore time I bought Serial to USB adapters. For some reason after a certain amount of data has gone between the device and the port, the app that is being used will just freeze because the port cut out or something. Only thing that works is port 4, which is the AMP_CTRL, I guess because there is no data transfer it doesnt give out.
      Nirwana Project, the Android/Win 7 hybrid system!

      1X Ainol Novo Flame Tab
      4X MK808b
      3x Perixx Touchpads
      3x 7 inch Screens
      1X 7 inch motorized Screen
      1x Win 7 PC

      Comment


      • #4
        I think maybe I have found the issue. Its a IRQ issue. I notice that when i have the USB PCI card plugged in, the sound card works in 24 bit mode. As soon as i plug in a serial device, the soundcard will go into 16 bit mode saying that bandwidth has been limited and must go into 16bit mode. I guess maybe i should try without the USB PCI card. I am starting to think this is the issue. i originally had a 5 port card, but it was fried. I then downsized to a 3 port card and have had issues ever since. When I get home, i am going to unplug the PCI card and see what happens.
        Nirwana Project, the Android/Win 7 hybrid system!

        1X Ainol Novo Flame Tab
        4X MK808b
        3x Perixx Touchpads
        3x 7 inch Screens
        1X 7 inch motorized Screen
        1x Win 7 PC

        Comment


        • #5
          OMFG, it was the USB PCI card. As soon as it was unplugged, all serial ports work. Also my graphic card issues have gone away. Going to buy a new USB card.
          Nirwana Project, the Android/Win 7 hybrid system!

          1X Ainol Novo Flame Tab
          4X MK808b
          3x Perixx Touchpads
          3x 7 inch Screens
          1X 7 inch motorized Screen
          1x Win 7 PC

          Comment

          Working...
          X