No announcement yet.

Motherboard and Touchscreen don't love each other...

  • Filter
  • Time
  • Show
Clear All
new posts

  • Motherboard and Touchscreen don't love each other...

    This is a little long, because I wanted to provide details in case someone has experience with the same or similar combination. Here's the summary:

    My ITOX motherboard USB ports do not recognize my Lilliput touchscreen. I've found a workaround, but I don't like it. I'm looking for help (and waiting on a response from ITOX)

    Here are the details:

    I bought a ITOX G5M100-N mini ITX motherboard with the Intel i855GME chipset. Specs here.

    I have a Newision branded Lilliput touchscreen that works great on any computer I put it on except this one.

    According to the specs, the rear USB connectors are 2.0/1.1, but Windows identifies them as 1.1 only (as does the post screen during boot). Plugging the touchscreen into any of them results in "Unidentified USB Device", regardless of which touchscreen drivers I use.

    There is a USB 2.0 header on the board, to which I attached a connector and plugged in the touchscreen. Also get "Unidentified USB Device" UNLESS I turn the monitor off, plug the touchscreen into the port, and then turn the monitor on. IF I do these things, the monitor is recognized by Windows and the Touchkit software. If I reboot, the monitor must be turned off or it will not be recognized on boot. HOWEVER, even though the touchscreen is recognized, it doesn't actually work. No input is recognized, and if I attempt to go to the "Hardware" screen in the Touchkit software, it is unable to read the details of the screen.

    I've tried updated chipset drivers for the motherboard (they don't appear to have anything more recent than 2004), all the flavors of drivers for the touchscreen, and even an Intel inf updater I found on Intel's website, but nothing has had any effect.

    Last night I purchased a USB 2.0 PCI card, put it in the single PCI slot available, plugged the touchscreen in and voila! A perfectly functioning touchscreen! Everythings works!

    Clearly my motherboard's USB ports are not working right, although I haven't had issues with any other device except this touchscreen. GPS, no problem. Powermate, no problem. Mouse, no problem. WiFi adaptor, no problem.

    Has anyone else used this motherboard? Have you had similar problems? Did you find a solution? How about this particular chipset? Is it known to have issues?

    As far as I know, all on-board USB drivers these days are provided by Microsoft as part of SP2. Am I wrong on this? Are there updated USB drivers I should be looking for?

    If anyone has experienced anything similar and share their ideas or solutions, I'd greatly appreciate it, as I really hate having a PCI-USB card in the one and only PCI slot on this board, when it already has 6 USB ports on the motherboard!



    (Sorry, this was supposed to go into the General Hardware forum)

  • #2
    i'm sure you already tried this, but have you installed/updated the USB 2.0 drivers?


    • #3
      Well, that's kind of an issue in that I can't find any such thing as updated USB 2.0 drivers for Windows XP. I have a disk from the motherboard manufacturer that includes USB drivers, but for Windows XP it just says "use the Microsoft drivers from SP1".

      The specs for the board indicate that the I/O chipset is the "Intel® 82801DB I/O Controller Hub (ICH4)". Is this what would control the USB functionality? I've done quite a bit of searching on Intel's site, and I can't find any references (in the downloads section) on this subsection of the board. Everything seems to be related to the 855 chipset as a whole. I've tried updating that, but no help.