No announcement yet.

BSOD then reboots ONLY when running off inverter(crashes every time I drive)

  • Filter
  • Time
  • Show
Clear All
new posts

  • BSOD then reboots ONLY when running off inverter(crashes every time I drive)

    I have gotten my carpc installed, and it was working just fine for the first two weeks. It takes me 30 minutes to drive to (and back) university on weekdays. When I drive, my computer will crash EVERYTIME I am driving. I will get a blue screen of death with a bugcheck 0xFE message titled BUGCODE_USB_DRIVER. This BSOD will pop up randomly when I drive, forcing me to reboot, and is totally unpredictable. I found a microsoft article on this problem: This microsoft article is useless. I dont think I can update my windows xp since I am using 2fastxp, and the site provides no alternatives. I have done much googling, but I have yet to find a solution. I also have completely no idea what this error code means. Like I mentioned previously, my carputer had been working fine for 2 weeks, now, all of a sudden, I am having this problem. The only USB device plugged into my computer is my LCD touchscreen (same as the MTSVO-SC). I have already tried reinstalling the touchscreen drivers and switching sticks of ram (incase it was due to bad ram). The most strange thing about my problem was that I only get this problem when I am driving and running my PC off the inverter. When I am at home, I did a test by plugging my computer into the wall and it ran stable even after many hours (in the car, I am almost guaranteed to crash within 30 mins). I had thought maybe EMF interference would be affecting the USB signal, so I even tried to relocate my inverter, running my wires 90 degrees to each other, and even shielding my cables and inverter with tin foil that is grounded (I put a piece of tin foil with a ground wire running out in a plastic bag, then wrapping the plastic bag around my inverter). However, despite all my efforts, I am STILL getting crashes. This problem is really annoying me. I am completely clueless as to whether this is a hardware or a software problem. If you guys could please offer more suggestions on what I can do, I would really appreciate it. Thanks!

  • #2
    Do you have USB boot enabled in the BIOS? If you do, turn it off.

    Also, could there be a short in the USB cable or extension that's causing it to screw up? An exposed connection of a USB extension could be doing this...
    Have you looked in the FAQ yet?
    How about the Wiki?

    Under normal circumstances, a signature would go here.


    • #3
      Your error is caused by loose USB connections causing a "short". This happens on cheap desktop cases when the front side USB ports arnt properly grounded and you touch the metal around the USB port with the male USB end when trying to put it in to the port.

      How do you fix it? Well, my advice is to use hot glue on your USB connections to prevent vibrations from shortting out the USB. I run a USB extension cable from my on-board ports to a USB Hub, use hot glue on that connection. I then hot glue in my GPS, touch screen, cd-rom, and other various devices.

      I use a second hub for a keyboard and mouse that I plug in when I want to use them. I use the same concept EXCEPT I ONLY hot glue the USB hub to the cable.


      • #4
        Could it possibly be a problem with the power supply? I've read that they sometimes don't like the square wave AC that cheaper inverters produce. The problem would them leave while pluged in at home because you're feeding it true sine wave AC then. Does it crash if you are running off the inverter, but the car isn't moving? if so that should eliminate vibration as the cause...


        • #5
          Thanks for all your replies. It turns out that it was because the inverter I was using was crap. I measured the voltage coming out, and it was only putting out 98 volts AC! I got a new inverter and everything is running stable. If only I had found this out before I did a complete format and reinstall.


          • #6
            Good, I'm glad that you got it figured out. It sounded lke a problem with the inverter to me based on your discriptions. Got any pics of the install?


            • #7
              Sure, I'll show you some pictures. I took these on the day when I just installed my system so everything was a mess. Try not to laugh at my inverter. I put the inverter together myself after I found the circuit board for free ^^
              My inverter actually worked fine for a week.

              Comments / criticism is welcome.


              • #8
                WOW! I've never heard of anyone building their own inverter before... too bad it didn't work out. Did you replace it with a comercial unit? And do you plan to troubleshoot that one to figure out what went wrong? I would, but then again I'm an EE, so that's no supprise.


                • #9
                  Yes, I dished out $40 CDN and bought a commercial 300 watt inverter.

                  I said I put it together, not build from scratch. A pawn shop was closing out and they were giving away free circuit boards. I just happened to grab a circuit board for an inverter. I still had to find a piece of wood to mount it, add an on-off switch, add heatsink and fan, replace some mosfets.

                  All my electronics/circuit board knowledge I learned myself, but I doubt I can troubleshoot this inverter. I have no professional electronics knowledge whatsoever (I am only a first yr university student).

                  There are some adjustable trimmer capacitors on the circuit board. Maybe when I have time, Ill mess around and see if they affect the output voltage.