Announcement

Collapse
No announcement yet.

Xport Issues

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Xport Issues

    Ive used Xport in the past with great results, due to a laptop bios failure I had to start all over with a different machine. I went to set up xport yesterday for use with iguidance and roadrunner. After a few minutes of running (working fine) either a error comes up saying an error has occurd and xport needs to shut down, or xport just shuts down with no warning. I've removed and reset it up a few times with the same outcome, any ideas?

  • #2
    Wow. I wonder how many people got that last one? Download the new version. Sorry.

    Comment


    • #3
      wow, speedy service. i'll try it out

      Comment


      • #4
        Hi Curiosity,

        I have used XPort for already a year to split GPS-Port, what was working fine.
        Now I bought a GPS/TMC-Mouse (Navilock 409TE) and I'm trying to get TMC-Signal into the navigation software. This doesn't really work. I managed to get TMC connected with the XPort verision 1.19, but GPS-Signal was very unstable, appearing and disappearing every 20 Seconds or so and apparently a BSOD. With the 1.20 I get GPS connected, but TMC on the other port cannot be initialized. Do I do something wrong or is XPort not designed to handle TMC-Data?
        Car: Volvo XC60
        CarPc: intel D945CLF2, 7"-Touchscreen, RoadRunner, IGo8
        HiFi: Diabolo D19/AndrianAudio A165g,2xPolk DB10, Signat RAMbo pimped, BRAX X2000

        Comment


        • #5
          I've never seen TMC data so I can't really give you an answer.

          Comment


          • #6
            would it help to send you the actual GPS log?
            Car: Volvo XC60
            CarPc: intel D945CLF2, 7"-Touchscreen, RoadRunner, IGo8
            HiFi: Diabolo D19/AndrianAudio A165g,2xPolk DB10, Signat RAMbo pimped, BRAX X2000

            Comment


            • #7
              Yes, I think that may help. Also, what do you mean by the "other" port? Is there more than one COM port and how do you initialize it?

              Comment


              • #8
                I'll grab it tonight and attach. *done*
                afaik TMC data is sprinkled among NMEA strings separated by "?"


                The SW I use (iGO8) needs GPS and TMC on separate ports, so I split the original signal with XPort and feed iGO with the virtual ports
                Attached Files
                Car: Volvo XC60
                CarPc: intel D945CLF2, 7"-Touchscreen, RoadRunner, IGo8
                HiFi: Diabolo D19/AndrianAudio A165g,2xPolk DB10, Signat RAMbo pimped, BRAX X2000

                Comment


                • #9
                  That can't be good. There is mixed text and binary in it. I see 3F D5 .... 3F inserted in the middle of NMEA sentences which should be causing problems with your software. It won't be able to find the TMC data in all that mess. It's kind of like 2 things are sending messages that don't know about each other. Try to find some kind of option that is designed to allow them both to work together if there is one. There could also be a baud rate setting for the TMC or second output that is different, but I really think it's made to output on seperate ports.

                  Comment


                  • #10
                    the funny thing is, it does. If I set a splitted port as TMC port in iGo and do not configure GPS properly, iGO receives TMC correctly.
                    ShowGPS receives NMEA and TMC on one port so the data seems to be correct.

                    Does XPort somehow parse/analyze received data or is it forwarded raw to the virtual ports?
                    Car: Volvo XC60
                    CarPc: intel D945CLF2, 7"-Touchscreen, RoadRunner, IGo8
                    HiFi: Diabolo D19/AndrianAudio A165g,2xPolk DB10, Signat RAMbo pimped, BRAX X2000

                    Comment


                    • #11
                      XPort does nothing with it. Your logs should look the same with or without XPort. The problem is that iGo can't deal with the NMEA broken up by the TMC data. Try ShowGPS through XPort. It should work just fine.

                      Comment


                      • #12
                        I'll test it. thanks
                        Car: Volvo XC60
                        CarPc: intel D945CLF2, 7"-Touchscreen, RoadRunner, IGo8
                        HiFi: Diabolo D19/AndrianAudio A165g,2xPolk DB10, Signat RAMbo pimped, BRAX X2000

                        Comment


                        • #13
                          Originally posted by LFPerf View Post
                          Ive used Xport in the past with great results, due to a laptop bios failure I had to start all over with a different machine. I went to set up xport yesterday for use with iguidance and roadrunner. After a few minutes of running (working fine) either a error comes up saying an error has occurd and xport needs to shut down, or xport just shuts down with no warning. I've removed and reset it up a few times with the same outcome, any ideas?
                          I had the same problem. Ill trry the new one at lunch today
                          -Jesus- King of Kings Lord of Lords

                          Comment


                          • #14
                            I've got it working with GPSGate, setting a NMEA filter. You were right, iGo doesn't understand broken NMEA data.
                            Car: Volvo XC60
                            CarPc: intel D945CLF2, 7"-Touchscreen, RoadRunner, IGo8
                            HiFi: Diabolo D19/AndrianAudio A165g,2xPolk DB10, Signat RAMbo pimped, BRAX X2000

                            Comment


                            • #15
                              I don't think any nav program can handle that, and that's why I think it's probably a wrong setting. But then if you can get it to work, that's good. I think I would have tried to work with a standard, like insert a $GPTMC,x,x,x,x*XX sentence in there so it would just automatically be ignored by anything that doesn't understand it. That would make things too simple though.

                              Comment

                              Working...
                              X