No announcement yet.

GPS serial port disappears?

  • Filter
  • Time
  • Show
Clear All
new posts

  • GPS serial port disappears?

    I have iGuidance 2009 and the USB GPS device that comes bundled with it. After about an hour on the road, iGuidance lost the GPS signal and when looking into Windows' "Device Manager" I can see that the GPS device's serial port (Prolific something-or-other) is missing.

    Rebooting got my serial port back, and iGuidance worked fine. But after a few minutes it happened again - nav stops working, serial port goes missing. I went through that 4-5 times before giving up.

    Disabling and re-enabling the (passive 4-port) hub that the GPS device was connected to would solve the problem, but that's pretty tedious.

    Has anyone seen this sort of thing before? I'm going to try replacing the hub with a different one, just to see if that's the problem, but I'm not very optimistic about that theory.

    If you remember my other thread about USB power, you'll be glad to know that I've removed a bunch of peripherals since then. All I have hooked up now is the USB touch screen, a Tactrix OBDII cable, and a LinkSys Bluetooth radio, and they all continued to work after this happened. The BT radio is the only one that can draw a non-trivial amount of power, and since I had no BT devices active I'm sure it was pretty much idle (discovery is off). So I don't think power draw is the problem here.

    If anyone has any theories on why the serial port keeps disappearing, I'd love to hear them.


  • #2
    If your GPS is plugged in through a USB hub, connect it directly to a USB port on the motherboard.

    Also, there is a power-saving setting on USB Root Hubs (in the device manager) that you should disable, if its not already.
    Have you looked in the FAQ yet?
    How about the Wiki?

    Under normal circumstances, a signature would go here.


    • #3
      I swapped the hub yesterday and the GPS worked for the whole 30 minutes that I had to drive... I'll be trying another long drive today (3 hours) and we'll see if it lasts.

      I kinda need a hub here so I'm hoping it's not absolutely necessary to plug in directly. My laptop only has two ports, and one of them goes to a passive hub in the dashboard (touch screen, OBD2, BT), the other goes to a passive hub in the trunk, where I need it for the W3bma5t3r power module and for the GPS (there's a sweet spot for the GPS antenna back there).

      Thanks for the tip about power saving, I will look into that regardless.


      • #4
        It worked for ~4 hours of driving yesterday (I think the longest stretch was about 1.5 hours), so apparently it was just a flakey hub.