No announcement yet.

Gps not locking in after upgrade

  • Filter
  • Time
  • Show
Clear All
new posts

  • Gps not locking in after upgrade

    I have a 32channel MTK usb GPS. I upgraded my MB/CPU/HDD and reinstalled Windows. I installed the USB-serial driver, and everything seems to work fine except that I can't get a lock.. Before it showed like 8 satellites, now 1 or 2 and never locks in. I took a long drive around the city and no luck.
    I tried it with iGuidance and Heavensea GPS Viewer. The communication log in Heavensea seems fine.

    This makes no sense to me, it worked great before, any ideas? It is mounted fairly deep inside the dash, but I'm reluctant to dig it out since it worked so well until now..

    Edit: I looked at this site and the two satellites I got were indeed 18 and 21 (the ones closest to me), so perhaps it really is badly positioned inside the dash, and I somehow 'got lucky' until now?

    Could the first lock-in after the reinstall be harder than the 'regular' ones? Does the driver/device store some information about the last location, which makes it easier to find satellites except the first time? Or something?

  • #2
    Ok, problem solved.
    I took it out of the dash temporarily and it started seeing 10 satellites, after it locked in I put it back, the signal strength decreased a lot, but still it works, and continues to work after power-off/on.
    So it works now, but I'll still move it on the dash, near the windshield.

    Edit: It stopped working again, I really must move it over the dash. I still don't understand why it worked before and it doesn't work now. And why it doesn't find satellites but if I pull it out and it locks on, then it can continue to communicate with 7-8 satellites from inside the dash.