No announcement yet.

Serial/USB Question (Sick of This...)

  • Filter
  • Time
  • Show
Clear All
new posts

  • Serial/USB Question (Sick of This...)

    I know this is a pretty common problem, and I've been digging through the forums, but honestly am getting tired of fighting the gps.

    Quick Question - Will getting the GPS that doesn't need a serial -> usb adapter still create all these comm port issues?

    Long Question - I have a serial gps that is attached via a converter to the usb. It worked fine on my old laptop when I was testing things, but is having all sorts of issues on the carpc. I've re-installed drivers, assigned all sorts of comm ports. Iguidance wants nothing to do with it.

    Is the problem from the change to the usb? I've downloaded xport, but am having a hard time figuring it out. (not as tech savvy as most here....)

    If getting a new gps receiver will get around these issues, it's totally worth the $40 at this point.

    Appreciate the help.

  • #2
    I have a USB BU-355 and I have no issues with drivers or anything. What ports are you assigning it too? I think iGuidance has issues with higher number ports. I had this problem before, I think it needs to be COM7 or lower.


    • #3
      All GPS's (I have seen) work as USB to serial, some just have the USB to serial stuff built into the GPS, so they detect as a USB to serial adapter themselves. Make sure you have the com port settings AND speeds correct. Verify the port (com1,2,3,etc) in device manager and then try 4800, 9600, etc for speeds on THAT com port in iguidance.
      Car: 2004 GTI VR6 24v Turbo 2.8L, GT35R, 630cc, Unitronic, Bosch 044, etc, etc..
      Main PC:i7 [email protected], 6GB DDR3, MSI X-58 Pro-E, Win 7 x64 RTM, Scythe Mugen2, 128GB G.Skill Falcon, 2x ATI4850 512MB Crossfire, Auzentech X-Fi Forte, Grado Labs SR-80


      • #4
        Thanks for the replies. I've played with my Comm ports (set them at 3, 4, 12...), and swapped the baud rate between 4800 and 9600. iguidance never found it, whether I did auto-detect or manual.

        Good to know that the usb versions are essentially serial with built in adapters. Saves me a bit of money I guess, just was hoping that would be an easy fix....

        I've re-installed XP, and upgraded to 7. This pc just doesn't want to find my gps. xport wasn't detecting the gps either, but I honestly was so annoyed at this point that I didn't play with it long.

        I did find drivers for the adapter, and installed that. Forget the name, but it's there.

        Annoying.... :/

        thanks again.


        • #5
          OK, I think this is kinda interesting, so I'm going to add it to the thread.

          Sometimes, in iguidance, the gps info is completely blank. Others (when it seems like i should have everything lined up correctly), the nmea box is full of info, the time seems to have updated, but I get 0/12 satellites. When I ask it to scan for the gps, it still comes up with nothing......


          • #6
            Okay, it worked on the laptop. Is it plugged in IDENTICALLY to when it was working? Or is the converter plugged into a USB hub?
            Originally posted by ghettocruzer
            I was gung ho on building a PC [until] just recently. However, between my new phone having internet and GPS and all...and this kit...Im starting to have trouble justfiying it haha.
            Want to:
            -Find out about the new iBug iPad install?
            -Find out about carPC's in just 5 minutes? View the Car PC 101 video


            • #7
              I've moved it around. I wanted to use it via a hub, but I've plugged it in directly, and I've removed the serial/usb adapter, just to try and get it going...... Actually playing with it now. Must've removed/re-installed the driver a dozen times tonight :P


              • #8
                It's working!!!! I don't know why exactly, but part of it was bringing it all upstairs so it can get a signal I guess. I still had to mess around, and was playing with ports/bauf rates/drivers, but I hit the magic combo it seems....... now, God willing, it will stick

                Huge success! Thanks to all (including those who've been through this before, since I ran through much of this based on others' experiences)

                Next step, getting xm to get all the channels


                • #9
                  As long as you've got it working that's great. There's nothing worse than having a GPS that doesn't work the way you want.

                  If you still have problems, I've had very good luck with my QStarz 818x. It does 5hz, but for some reason Xport can use it...and Garmin can use it...both at the same time. Garmin just says "QStarz GPS" in it's gps setup, all the while Xport reports a connection and will flow GPS data to the virtual serial ports to iGuidance.

                  Paid about $64 from buygpsnow. I've also tried the Canmore GPS dongles. They work good as well however I believe they either have some firmware or driver issues as sometimes it gets detected as a USB mouse and things go haywire. When it's detected as a GPS (which is most of the time) it does work well. Has good tracking but the sensitivity doesn't seem to be as good as the QStarz unit.