No announcement yet.

iblue gm-2, driver issues...

  • Filter
  • Time
  • Show
Clear All
new posts

  • iblue gm-2, driver issues...

    Ever since I've done my re-build about 2 months ago, I got around to finally putting in some usb hubs. In the mix of all the re-building the system, I upgraded plenty of parts, but in the whole process I can't find or can't remember if the iblue gm-2 usb gps device came with drivers/software discs...

    I searched online, as device manager tells me Cp2102x... and that in turn leads to silabs USB to UART bridge. That turned out installing a driver and vcp. After a re-boot of the machine, the touchscreen went crazy, like constant moving clicking on the screen. I unplugged my phone, no help, unplugged wifi adapter, no help. I unplugged the gps device and the clicking/moving of the pointer stopped. Looked in device manager and found 2 new items. One was a microsoft USB Serial Ball Mouse (or something like it). I can't remember the other cause I un-installed the silabs stuff...

    Now, since I know that wasn't supposed to happen, I am in search of someone who might know or still have drivers for this gps device. It used to work well on my old install, but that was about a day after I got the gps device, so I bet I had drivers that came with it...

    Edit - I should add I tried a couple different versions of gpsview, and couldn't figure them out, but saw no data in either programs as well.
    Current Worklog: TBA - '05 Rav4 (Mobo Dead). - Forums for Rav4 owners - Cooking website/forums
    -Basic forums live atm, come contribute!

  • #2
    Maybe this will help:

    As for your touchscreen going crazy I had the same issue. I can't remember exactly what driver caused it, but I know that windows update installed it. I ended up just rolling back the updates and fixed my issue.
    Last edited by kiru; 02-15-2012, 09:24 PM.


    • #3
      Wow... Anyone remember this post? I finally got around to transferring the drivers linked above into the car. I ran the cp21xx setup/installer file while leaving the usb gps UN-plugged. After the install of the drivers, I plugged the usb gps in and it recognized it as installed. The touch screen did not go crazy, so that's a step above whatever I tried back when I started the post.

      I installed a brand new version of Navigator Setup Utility, downloaded the OpenStreetMaps of Pennsylvania, and installed the Navigator program. Inside Navigator Free in the settings, I went into the GPS settings and with an automatic search, it found the correct com port and baud rate. It connected to about 10 satellites right away. Woot!

      There are a couple things I cannot for the life of me figure out though... How to search for an address inside Navigator Free? Everytime I click the Navigate/Search/Route/whatever buttons, I click the textbox to bring up the keyboard. However, The keyboard or anywhere on the screen doesn't have a search/accept/whatever button. I can click through State/City lists but it doesn't even list the major streets in my city. If I click to search the internet instead of the original textbox, I type in my address and it finds it, apparently it uses a google search.

      I am not always connected to wifi in my car, and OSM lists all the street names while I'm driving around anyways, so I cannot understand why I can't search for an address (let alone find major streets). I understand this might be an issue with Navigator or OSM, but I'm typing this out in case anyone might have some forethought into this...

      The other thing is my gps doesn't seem to connect, or Navigator doesn't seem to pick it back up, on resuming from hibernate. This can be remedied by unchecking the gps in Navigator settings, and checking gps again. When resuming, Navigator has a screen that the device timed out or something. I changed a setting so it's not supposed to prevent standby anymore. I haven't tested this yet. Windows went through it's normal hibernate routine so I figure this won't change anything...

      Thanks again for the link above - those drivers worked well so far.

      EDIT - I forgot to say that my gps IS plugged into a powered usb hub, powered from a switched voltage source.
      Last edited by detlion1643; 11-29-2012, 09:05 PM.
      Current Worklog: TBA - '05 Rav4 (Mobo Dead). - Forums for Rav4 owners - Cooking website/forums
      -Basic forums live atm, come contribute!