Announcement

Collapse
No announcement yet.

Selecting COM port in Destinator 2 SDK and USB EMate

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Selecting COM port in Destinator 2 SDK and USB EMate

    Is there a trick to selecting the COM port when using Destinator2 SDK and a USB Delorme Earthmate? When I go to GPS Settings in my car, I can only choose COM2 [COM1 - Xenarc, COM2 - empty, COM3 - Virtual from USB EMate]. While at home, I can choose any from COM1-COM3, but the EMate is on COM4. So how do I select the Delorme's COM port from Destinator?

    Also, I was searching the other threads, and someone mentioned editting the Destinator.inf file to get an on-screen keyboard. I looked in the file and saw alot of lines, including ones that starts "::B:KEYBOARD..." but I don't know what to edit to what values. Does anyone have a list of these entries and what the numbers mean? Maybe I can change the size of buttons, also?

    Thanks in advance for advice,
    --Ed

  • #2
    : for keyboard Change the 639 to the width of your screen (or at least 640)

    My GPS (not Delorme) is USB, and shows up as a Com Port in Device manager, and I can select it in Destinator just fine.

    Have you tried to auto check for the GPS?


    Garry
    Co-Developer of A.I.M.E.E
    www.aimee.cc

    Comment


    • #3
      Originally posted by Sensor
      Is there a trick to selecting the COM port when using Destinator2 SDK and a USB Delorme Earthmate? When I go to GPS Settings in my car, I can only choose COM2 [COM1 - Xenarc, COM2 - empty, COM3 - Virtual from USB EMate]. While at home, I can choose any from COM1-COM3, but the EMate is on COM4. So how do I select the Delorme's COM port from Destinator?
      I had the same problem with the Earthmate. Here's what I remember about getting it to work. In destinator go into the GPS setup and select com2 and change the baud rate to 4800. Go into the Control Panel and bring up the Earthmate. Now, theres an advanced setup menu or something like that where you can change the Earthmate to com2 and 4800. It should work now-might need to reboot. I think the key is to change the baud rate in destinator to 4800. I know that the Emate USB works with Destinator because I had mine running this way before I bought my serial cable.
      '03 Sierra Denali

      Comment

      Working...
      X